Subject: Upgrading doc does not mention pg_restore at all

From: Josh Berkus <[email-masked]>
Date: Fri, 10 Jan 2014 10:18:48 -0800

Folks:

http://www.postgresql.org/docs/9.3/static/upgrading.html

... no mention of pg_restore of any kind.  Is there any reason why
someone (maybe me) *shouldn't* rewrite this to include pg_restore?

Frankly, I think recommending psql to restore is a bad idea ...

-- 
Josh Berkus
PostgreSQL Experts Inc.
http://pgexperts.com

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: Magnus Hagander <[email-masked]>
Date: Sat, 11 Jan 2014 12:47:43 +0100

> someone (maybe me) *shouldn't* rewrite this to include pg_restore?

I can't see any reason - it definitely should mention it.

Yes. And recommending pg_dumpall > sqlfile, but that goes hand in hand with
that.

It also says that the least-downtime way is to use pg_dumpall in a pipe to
psql. That's clearly not correct, since it does not support parallel
restore (or parallel dump).

In short, +1 for you to write a patch that changes that.

It could probably deserve a better descirption of pg_upgrade as well, and
an outline of the differences. Right now we spend the majority of the page
on pg_dump, and then just say "oh, with pg_upgrade it only takes minutes"...

-- 
 Magnus Hagander
 Me: http://www.hagander.net/
 Work: http://www.redpill-linpro.com/

---

From: Josh Berkus <[email-masked]>
Date: Sat, 11 Jan 2014 19:20:57 -0800

> on pg_dump, and then just say "oh, with pg_upgrade it only takes minutes"...

Bruce can do that part.

-- 
Josh Berkus
PostgreSQL Experts Inc.
http://pgexperts.com

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 10 Apr 2014 20:02:33 -0400

> Yes. And recommending pg_dumpall > sqlfile, but that goes hand in hand with

Yes, it is pg_dumpall that is driving the psql example.  Should we just
reference the SQL Dump section of our docs rather than giving examples
in this section?  I am noticing we don't warn about the pg_dumpall
--globals-only requirement anywhere in our SQL Dump docs, and I don't
see it in the reference pages either.

> psql. That's clearly not correct, since it does not support parallel restore
> (or parallel dump). 
> 

OK.

> It could probably deserve a better description of pg_upgrade as well, and an
> outline of the differences. Right now we spend the majority of the page on
> pg_dump, and then just say "oh, with pg_upgrade it only takes minutes"...

OK, I will try to work on that.   I think I am going to need to change
several parts of the docs to complete this.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + Everyone has their own god. +

---

From: Bruce Momjian <[email-masked]>
Date: Mon, 25 Aug 2014 13:58:39 -0400

FYI, I have merged these suggestions into a later thread, that includes
a patch:

	http://www.postgresql.org/message-id/flat/[email-masked][email-masked]

---------------------------------------------------------------------------