Subject: ubuntu deb packaging

From: Rob Sargent <[email-masked]>
Date: Wed, 21 Oct 2015 17:34:58 -0600

1. I have a shiny new desktop running
cat /etc/os-release
NAME="Ubuntu"
VERSION="14.04.3 LTS, Trusty Tahr"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 14.04.3 LTS"
VERSION_ID="14.04"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"

2. Unfortunately I thought it was 14.10 and first put "utopic" in the list
file but that didn't work.  big surpries.
3. But now
cat /etc/apt/sources.list.d/pgdg.list
deb http://apt.postgresql.org/pub/repos/apt/ trusty-pgdg main

4.. and after running sudo apt-get update I do indeed get psql. But is this
to be expected?
psql --version
psql (Postgres-XC) 1.1
(based on PostgreSQL) 9.2.4

Dis (mis)step 2 do me in?  Should I not see psql version closer to 9.4?

---

From: Magnus Hagander <[email-masked]>
Date: Fri, 23 Oct 2015 18:36:23 +0200

On Thu, Oct 22, 2015 at 1:34 AM, Rob Sargent <[email-masked]> wrote:

> 4.. and after running sudo apt-get update I do indeed get psql. But is
> this to be expected?
> psql --version
> psql (Postgres-XC) 1.1
You seem to have installed psql from Postgres XC rather than from
PostgreSQL. Look if you have any of the XC packages installed and then
remove those, replacing them with the PostgreSQL ones.

-- 
 Magnus Hagander
 Me: http://www.hagander.net/
 Work: http://www.redpill-linpro.com/

---

From: Rob Sargent <[email-masked]>
Date: Fri, 23 Oct 2015 11:18:39 -0600

On 10/23/2015 10:36 AM, Magnus Hagander wrote:
>
>
> On Thu, Oct 22, 2015 at 1:34 AM, Rob Sargent <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     2. Unfortunately I thought it was 14.10 and first put "utopic" in
>     the list file but that didn't work.  big surpries.
>     3. But now
>     4.. and after running sudo apt-get update I do indeed get psql.
>     But is this to be expected?
>     psql --version
>     psql (Postgres-XC) 1.1
Thanks Magnus,

removed the xc package, loaded synaptic and got pg9.4.