Subject: Suggestion on Document for Version 12 Section 40.3

From: PG Doc comments form <[email-masked]>
Date: Thu, 09 Jan 2020 08:28:05 +0000

The following documentation comment has been logged on the website:

Page: https://www.postgresql.org/docs/12/rules-materializedviews.html
Description:

Hello all,

I'm reading Section 40.3, and there is an example (the third square by
reverse order):

SELECT word FROM words ORDER BY word <-> 'caterpiler' LIMIT 10;

     word     
---------------
 cater
 caterpillar
 Caterpillar
 caterpillars
 caterpillar's
 Caterpillar's
 caterer
 caterer's
 caters
 catered
(10 rows)

As shown here https://www.postgresql.org/docs/current/pgtrgm.html, the
operator `<->` is in an additional module. Without the context, the reader
will need searching to help understand the meaning. It would be better if
further reference is given.

Yushan

---

From: Daniel Gustafsson <[email-masked]>
Date: Thu, 9 Jan 2020 10:42:10 +0100

> On 9 Jan 2020, at 09:28, PG Doc comments form <[email-masked]> wrote:
> 

I agree that this could lead to unnecessary confusion for readers, and since we
are already mentioning that file_fdw is used it seems reasonable to also
mention pg_trgm.  A suggested patch is attached.

cheers ./daniel

---

From: Magnus Hagander <[email-masked]>
Date: Thu, 9 Jan 2020 10:50:14 +0100

> mention pg_trgm.  A suggested patch is attached.

Seems correct. Pushed, thanks!

//Magnus