Subject: Default value for the defaultAutoCommit property

From: Celinio Fer <[email-masked]>
Date: Thu, 3 Jun 2021 07:49:21 +0000 (UTC)

Hi,
I wonder if the documentation for the JDBC PostgreSQL driver is up to date :
https://jdbc.postgresql.org/documentation/head/ds-cpds.html#ds-cpds-props
It is written that the default value for the defaultAutoCommit  property  is false.

However in the source code, the default value is true :
https://github.com/pgjdbc/pgjdbc/blob/master/pgjdbc/src/main/java/org/postgresql/ds/PGConnectionPoolDataSource.java

private boolean defaultAutoCommit = true;
...
/**
   * Gets whether connections supplied by this pool will have autoCommit turned on by default. The
   * default value is {@code true}, so that autoCommit will be turned on by default.
   *
   * @return true if connections supplied by this pool will have autoCommit
   */
  public boolean isDefaultAutoCommit() {
    return defaultAutoCommit;
  }

Did i miss something ?
Thanks
Celinio

---

From: Dave Cramer <[email-masked]>
Date: Thu, 3 Jun 2021 06:31:41 -0400

Good catch.

Thanks, I will fix that.
Dave Cramer
www.postgres.rocks