Subject: doc: Fix the header file where CompareType is defined in gist.sgml

From: Daisuke Higuchi <[email-masked]>
Date: Sat, 13 Dec 2025 17:24:48 +0900

Hi

I found that the header file where CompareType was actually defined did not
match the header file described in gist.sgml.
CompareType is currently defined at "src/include/access/cmptype.h" instead
of "src/include/nodes/primnodes.h".
This change was made in the commit below, but it seems that documentation
update was missed.

https://github.com/postgres/postgres/commit/119fc30dd5bd918819b864107ddc8baac51f4d22

Regards

---

From: Paul A Jungwirth <[email-masked]>
Date: Mon, 15 Dec 2025 15:19:34 -0800

On Sat, Dec 13, 2025 at 12:25 AM Daisuke Higuchi
<[email-masked]> wrote:
>
> I found that the header file where CompareType was actually defined did not match the header file described in gist.sgml.
> CompareType is currently defined at "src/include/access/cmptype.h" instead of "src/include/nodes/primnodes.h".
> This change was made in the commit below, but it seems that documentation update was missed.
>

You're right, that's where we define it. Your email landed in Gmail's
spam folder for me, so hopefully this +1 will help it not be missed by
a committer.

Yours,

-- 
Paul              ~{:-)
[email-masked]

---

From: Daniel Gustafsson <[email-masked]>
Date: Tue, 16 Dec 2025 09:50:22 +0100

> On 16 Dec 2025, at 00:19, Paul A Jungwirth <[email-masked]> wrote:
> 

Thanks for the report, fixing it right now.

--
Daniel Gustafsson