Subject: doc: Fix missing or duplicate closing parentheses in some documents

From: Daisuke Higuchi <[email-masked]>
Date: Fri, 7 Nov 2025 10:40:48 +0900

Hi
I found that the parentheses seemed not to be handled correctly in
following 3 documents, so I attach the patch for this.

- closing parentheses is missing
  - doc/src/sgml/client-auth.sgml

- closing parentheses is duplicate
  - doc/src/sgml/ltree.sgml
  - doc/src/sgml/trigger.sgml

Regards

---

From: Erik Wienhold <[email-masked]>
Date: Fri, 7 Nov 2025 05:08:27 +0100

>   - doc/src/sgml/trigger.sgml

All three changes make sense.  Although I would rephrase the part in
client-auth.sgml from this:

"a regular expression (when starting with a slash (<literal>/</literal>))"

to this:

"a regular expression starting with a slash (<literal>/</literal>)"

The latter reads nicer IMO and avoids the double closing parenthesis
which I find a bit awkward.

-- 
Erik Wienhold

---

From: Daisuke Higuchi <[email-masked]>
Date: Fri, 7 Nov 2025 13:39:07 +0900

Thank you for checking!

>"a regular expression starting with a slash (<literal>/</literal>)"

Yes, I agree with you. I also think this is easier to read.

Regards,

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 7 Nov 2025 22:19:59 -0500

> Yes, I agree with you. I also think this is easier to read.

Very good, patches applied with adjustment by Erik Wienhold.

---------------------------------------------------------------------------

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  Do not let urgent matters crowd out time for investment in the future.