Subject: Dead link in ltree documentation

From: PG Doc comments form <[email-masked]>
Date: Wed, 04 Apr 2018 09:59:23 +0000

The following documentation comment has been logged on the website:

Page: https://www.postgresql.org/docs/10/static/ltree.html
Description:

Hi, 

https://www.postgresql.org/docs/current/static/ltree.html links to
www.dmoz.org which now returns a 403, since being closed down in 2017. 

Maybe it could link to the mirror https://dmoztools.net/ or the wikipedia
page instead.

---

From: Oleg Bartunov <[email-masked]>
Date: Wed, 4 Apr 2018 15:46:06 +0300

Postgres Professional: http://www.postgrespro.com
The Russian Postgres Company

> Maybe it could link to the mirror https://dmoztools.net/ or the wikipedia

Attached is a small patch.

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 4 Apr 2018 15:06:36 -0400

> --- ltree.sgml.orig	2017-12-20 16:40:26.000000000 +0300
> +++ ltree.sgml	2018-04-04 15:43:01.000000000 +0300
> @@ -34,7 +34,7 @@
>     length of a label path must be less than 65kB, but keeping it under 2kB is
>     preferable.  In practice this is not a major limitation; for example,
>     the longest label path in the DMOZ catalog (<ulink
> -   url="http://www.dmoz.org"></ulink>) is about 240 bytes.
> +   url="http://www.dmoztools.net"></ulink>) is about 271 bytes.
>    </para>
>  
>    <para>

Patch applied back through 9.3.  Thanks.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

+ As you are, so once was I.  As I am, so you will be. +
+                      Ancient Roman grave inscription +

---

From: "David G. Johnston" <[email-masked]>
Date: Wed, 4 Apr 2018 13:02:33 -0700

> Patch applied back through 9.3.  Thanks.

​I'm not seeing the value in providing a link, especially one that we don't
control, here.  Futhermore, we could probably drop the whole "In
practice..." sentence.  But if not at least put a period after "limitation"
and drop the example and link.

​David J.

---

From: "David G. Johnston" <[email-masked]>
Date: Wed, 4 Apr 2018 13:13:32 -0700

> On Wed, Apr 4, 2018 at 12:06 PM, Bruce Momjian <[email-masked]> wrote:

FYI - Bruce's "I've committed this" email is the only one in the thread
that made it into my inbox...pgsql-docs emails seem to be getting swallowed
in the void sometimes.​

​David J.​

---

From: Alvaro Herrera <[email-masked]>
Date: Wed, 4 Apr 2018 17:17:13 -0300

> and drop the example and link.

+1 remove the sentence.

-- 
Álvaro Herrera                https://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services

---

From: Oleg Bartunov <[email-masked]>
Date: Thu, 5 Apr 2018 11:54:19 +0000

On Wed, Apr 4, 2018 at 8:17 PM, Alvaro Herrera <[email-masked]> wrote:
> David G. Johnston wrote:
>
>> I'm not seeing the value in providing a link, especially one that we don't

Attached is a new patch, which removed the whole sentence with example link.

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 5 Apr 2018 15:55:59 -0400

> Attached is a new patch, which removed the whole sentence with example link.

Patch applied and backpatched through 9.3.  Thanks.