Subject: Add JSON to the list of acronyms in the documentation's appendix

From: [email-masked]
Date: Tue, 24 Oct 2017 20:18:49 +0000

The following documentation comment has been logged on the website:

Page: https://www.postgresql.org/docs/10/static/acronyms.html
Description:

Hello all,

I propose to add &#39;JSON&#39; (for JavaScript Object Notation, http://json.org) to
the list of acronyms in the documentation&#39;s appendix
(https://www.postgresql.org/account/comments/new/10/acronyms.html/).

Best wishes,
  —Torsten

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 11 Jan 2018 11:22:24 -0500

> (https://www.postgresql.org/account/comments/new/10/acronyms.html/).

Good idea.  Patch applied --- it will appear in PG 11.

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

+ As you are, so once was I.  As I am, so you will be. +
+                      Ancient Roman grave inscription +
diff --git a/doc/src/sgml/acronyms.sgml b/doc/src/sgml/acronyms.sgml
new file mode 100644
index 6e9fddf..751c46d
*** a/doc/src/sgml/acronyms.sgml
--- b/doc/src/sgml/acronyms.sgml
***************
*** 370,375 ****
--- 370,385 ----
     </varlistentry>
  
     <varlistentry>
+     <term><acronym>JSON</acronym></term>
+     <listitem>
+      <para>
+       <ulink
+       url="http://json.org">JavaScript Object Notation</ulink>
+      </para>
+     </listitem>
+    </varlistentry>
+ 
+    <varlistentry>
      <term><acronym>LDAP</acronym></term>
      <listitem>
       <para>

---

From: Oleg Bartunov <[email-masked]>
Date: Thu, 11 Jan 2018 20:13:28 +0300

> Good idea.  Patch applied --- it will appear in PG 11.

Then, why not add JSONB !

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 11 Jan 2018 15:10:47 -0500

> Then, why not add JSONB !

Uh, most of those acronyms are for _externally_ defined terms.