Subject: bloom documentation patch

From: Oleg Bartunov <[email-masked]>
Date: Mon, 15 Oct 2018 00:14:32 +0300

Hi,

Please, consider attached patch, which improves contrib/bloom documentation.

Best regards,
Oleg
-- 
Postgres Professional: http://www.postgrespro.com
The Russian Postgres Company

---

From: Thomas Munro <[email-masked]>
Date: Mon, 15 Oct 2018 10:47:27 +1300

> Please, consider attached patch, which improves contrib/bloom documentation.

Hello Oleg, I have no comment on the technical details but here is
some proof-reading of the English:

+      Length of each signature (index entry) in bits, it is rounded
up to the nearest
+      multiple of 16. The default is <literal>80</literal> bits and maximum is

s/, it is/.  It is/
s/and maximum/and the maximum/

+       Bloom AM doesn't supports <literal>unique</literal> indexes.

s/supports/support/

+       Bloom AM doesn't supports <literal>NULL</literal> values.

s/supports/support/

-- 
Thomas Munro
http://www.enterprisedb.com

---

From: Oleg Bartunov <[email-masked]>
Date: Wed, 17 Oct 2018 23:45:30 +0300

> +       Bloom AM doesn't supports <literal>NULL</literal> values.

Thanks, Thomas, new patch attached.

---

From: Alexander Korotkov <[email-masked]>
Date: Mon, 22 Oct 2018 00:33:42 +0300

> > s/and maximum/and the maximum/

Thank you for these corrections.  They are pushed.

> > +       Bloom AM doesn't supports <literal>NULL</literal> values.

These two were already fixed in the version I've pushed before.

------
Alexander Korotkov