Subject: pg_class.relminmxid and pg_database.datminmxid

From: Fujii Masao <[email-masked]>
Date: Thu, 4 Jun 2015 00:59:44 +0900

Hi,

The descriptions of pg_class.relminmxid and pg_database.datminmxid
have some minor problems in the doc. Seems the attached patch needs
to be applied.

Regards,

-- 
Fujii Masao
*** a/doc/src/sgml/catalogs.sgml
--- b/doc/src/sgml/catalogs.sgml
***************
*** 2018,2025 ****
         All multitransaction IDs before this one have been replaced by a
         transaction ID in this table.  This is used to track
         whether the table needs to be vacuumed in order to prevent multitransaction ID
!        ID wraparound or to allow <literal>pg_clog</> to be shrunk.  Zero
!        (<symbol>InvalidTransactionId</symbol>) if the relation is not a table.
        </entry>
       </row>
  
--- 2018,2025 ----
         All multitransaction IDs before this one have been replaced by a
         transaction ID in this table.  This is used to track
         whether the table needs to be vacuumed in order to prevent multitransaction ID
!        wraparound or to allow <literal>pg_multixact</> to be shrunk.  Zero
!        (<symbol>InvalidMultiXactId</symbol>) if the relation is not a table.
        </entry>
       </row>
  
***************
*** 2686,2692 ****
         All multitransaction IDs before this one have been replaced with a
         transaction ID in this database.  This is used to
         track whether the database needs to be vacuumed in order to prevent
!        transaction ID wraparound or to allow <literal>pg_clog</> to be shrunk.
         It is the minimum of the per-table
         <structname>pg_class</>.<structfield>relminmxid</> values.
        </entry>
--- 2686,2692 ----
         All multitransaction IDs before this one have been replaced with a
         transaction ID in this database.  This is used to
         track whether the database needs to be vacuumed in order to prevent
!        multitransaction ID wraparound or to allow <literal>pg_multixact</> to be shrunk.
         It is the minimum of the per-table
         <structname>pg_class</>.<structfield>relminmxid</> values.
        </entry>

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: Alvaro Herrera <[email-masked]>
Date: Wed, 3 Jun 2015 15:22:36 -0300

> have some minor problems in the doc. Seems the attached patch needs

Looks reasonable.  I'm not sure about the term "multitransaction"
anymore; we use "multixact" elsewhere (notably in the section that
explains freezing, in the maintenance chapter).

Make sure to backpatch to 9.3 ...

-- 
Álvaro Herrera                http://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services

---

From: Fujii Masao <[email-masked]>
Date: Thu, 4 Jun 2015 12:35:10 +0900

> explains freezing, in the maintenance chapter).

Yes, we seem to have priority use of "multixact". OTOH, I found that
"multitransaction" is also used elsewhere, for example, in storage.sgml
(description of pg_multixact directory), pg_resetxlog.sgml and pgrowlocks.sgml.
Maybe it's better to use "multixact" even there...

Anyway I will push the fix with the term "multixact".

Regards,

-- 
Fujii Masao