Subject: pg_file_settings and catalog.sgml

From: Fujii Masao <[email-masked]>
Date: Fri, 12 Jun 2015 01:47:44 +0900

Hi,

System catalogs and views should be listed in alphabetical order,
but only pg_file_settings view not. The attached patch fixes this
alphabetization.

The patch also fixes two typos in comments related to pg_file_settings.

Regards,

-- 
Fujii Masao
*** a/doc/src/sgml/catalogs.sgml
--- b/doc/src/sgml/catalogs.sgml
***************
*** 7625,7630 ****
--- 7625,7635 ----
       </row>
  
       <row>
+       <entry><link linkend="view-pg-file-settings"><structname>pg_file_settings</structname></link></entry>
+       <entry>file location of parameter settings</entry>
+      </row>
+ 
+      <row>
        <entry><link linkend="view-pg-group"><structname>pg_group</structname></link></entry>
        <entry>groups of database users</entry>
       </row>
***************
*** 7680,7690 ****
       </row>
  
       <row>
-       <entry><link linkend="view-pg-file-settings"><structname>pg_file_settings</structname></link></entry>
-       <entry>file location of parameter settings</entry>
-      </row>
- 
-      <row>
        <entry><link linkend="view-pg-shadow"><structname>pg_shadow</structname></link></entry>
        <entry>database users</entry>
       </row>
--- 7685,7690 ----
***************
*** 7999,8004 ****
--- 7999,8077 ----
  
   </sect1>
  
+  <sect1 id="view-pg-file-settings">
+   <title><structname>pg_file_settings</structname></title>
+ 
+   <indexterm zone="view-pg-file-settings">
+    <primary>pg_file_settings</primary>
+   </indexterm>
+ 
+   <para>
+    The view <structname>pg_file_settings</structname> provides the file
+    name, line number and value of all parameters which are set through
+    configuration files.
+    In contrast to <structname>pg_settings</structname>, a row is provided for
+    each occurrence of the parameter across all configuration files. This is helpful
+    for discovering why one value may have been used in preference to another
+    when the parameters were loaded.
+   </para>
+ 
+   <table>
+    <title><structname>pg_file_settings</> Columns</title>
+ 
+   <tgroup cols="3">
+    <thead>
+     <row>
+      <entry>Name</entry>
+      <entry>Type</entry>
+      <entry>Description</entry>
+     </row>
+    </thead>
+    <tbody>
+     <row>
+      <entry><structfield>sourcefile</structfield></entry>
+      <entry><structfield>text</structfield></entry>
+      <entry>Path to and name of the configration file</entry>
+     </row>
+     <row>
+      <entry><structfield>sourceline</structfield></entry>
+      <entry><structfield>integer</structfield></entry>
+      <entry>
+       Line number within the configuration file where the value was set
+      </entry>
+     </row>
+     <row>
+      <entry><structfield>seqno</structfield></entry>
+      <entry><structfield>integer</structfield></entry>
+      <entry>Order in which the setting was loaded</entry>
+     </row>
+     <row>
+      <entry><structfield>name</structfield></entry>
+      <entry><structfield>text</structfield></entry>
+      <entry>Run-time configuration parameter name</entry>
+     </row>
+     <row>
+      <entry><structfield>setting</structfield></entry>
+      <entry><structfield>text</structfield></entry>
+      <entry>value of the parameter</entry>
+     </row>
+    </tbody>
+   </tgroup>
+  </table>
+ 
+   <para>
+    See <xref linkend="config-setting"> for more information about the various
+    ways to change these parameters.
+   </para>
+ 
+   <para>
+    The <structname>pg_file_settings</structname> view cannot be modified
+    directly as it represents information, as read in at server start or
+    reload time, about all parameter settings across all configuration files.
+   </para>
+ 
+ </sect1>
+ 
   <sect1 id="view-pg-group">
    <title><structname>pg_group</structname></title>
  
***************
*** 9306,9384 **** SELECT * FROM pg_locks pl LEFT JOIN pg_prepared_xacts ppx
  
   </sect1>
  
-  <sect1 id="view-pg-file-settings">
-   <title><structname>pg_file_settings</structname></title>
- 
-   <indexterm zone="view-pg-file-settings">
-    <primary>pg_file_settings</primary>
-   </indexterm>
- 
-   <para>
-    The view <structname>pg_file_settings</structname> provides the file
-    name, line number and value of all parameters which are set through
-    configuration files.
-    In contrast to <structname>pg_settings</structname>, a row is provided for
-    each occurrence of the parameter across all configuration files. This is helpful
-    for discovering why one value may have been used in preference to another
-    when the parameters were loaded.
-   </para>
- 
-   <table>
-    <title><structname>pg_file_settings</> Columns</title>
- 
-   <tgroup cols="3">
-    <thead>
-     <row>
-      <entry>Name</entry>
-      <entry>Type</entry>
-      <entry>Description</entry>
-     </row>
-    </thead>
-    <tbody>
-     <row>
-      <entry><structfield>sourcefile</structfield></entry>
-      <entry><structfield>text</structfield></entry>
-      <entry>Path to and name of the configration file</entry>
-     </row>
-     <row>
-      <entry><structfield>sourceline</structfield></entry>
-      <entry><structfield>integer</structfield></entry>
-      <entry>
-       Line number within the configuration file where the value was set
-      </entry>
-     </row>
-     <row>
-      <entry><structfield>seqno</structfield></entry>
-      <entry><structfield>integer</structfield></entry>
-      <entry>Order in which the setting was loaded</entry>
-     </row>
-     <row>
-      <entry><structfield>name</structfield></entry>
-      <entry><structfield>text</structfield></entry>
-      <entry>Run-time configuration parameter name</entry>
-     </row>
-     <row>
-      <entry><structfield>setting</structfield></entry>
-      <entry><structfield>text</structfield></entry>
-      <entry>value of the parameter</entry>
-     </row>
-    </tbody>
-   </tgroup>
-  </table>
- 
-   <para>
-    See <xref linkend="config-setting"> for more information about the various
-    ways to change these parameters.
-   </para>
- 
-   <para>
-    The <structname>pg_file_settings</structname> view cannot be modified
-    directly as it represents information, as read in at server start or
-    reload time, about all parameter settings across all configuration files.
-   </para>
- 
- </sect1>
- 
   <sect1 id="view-pg-shadow">
    <title><structname>pg_shadow</structname></title>
  
--- 9379,9384 ----
*** a/src/backend/utils/misc/guc.c
--- b/src/backend/utils/misc/guc.c
***************
*** 8182,8188 **** show_all_settings(PG_FUNCTION_ARGS)
   * show_all_file_settings
   *
   * returns a table of all parameter settings in all configuration files
!  * which includes the config file path/name, filename, a sequence number
   * indicating when we loaded it, the parameter name, and the value it is
   * set to.
   *
--- 8182,8188 ----
   * show_all_file_settings
   *
   * returns a table of all parameter settings in all configuration files
!  * which includes the config file path/name, the line number, a sequence number
   * indicating when we loaded it, the parameter name, and the value it is
   * set to.
   *
***************
*** 8208,8215 **** show_all_file_settings(PG_FUNCTION_ARGS)
  		oldcontext = MemoryContextSwitchTo(funcctx->multi_call_memory_ctx);
  
  		/*
! 		 * need a tuple descriptor representing NUM_PG_SETTINGS_ATTS columns
! 		 * of the appropriate types
  		 */
  
  		tupdesc = CreateTemplateTupleDesc(NUM_PG_FILE_SETTINGS_ATTS, false);
--- 8208,8215 ----
  		oldcontext = MemoryContextSwitchTo(funcctx->multi_call_memory_ctx);
  
  		/*
! 		 * need a tuple descriptor representing NUM_PG_FILE_SETTINGS_ATTS
! 		 * columns of the appropriate types
  		 */
  
  		tupdesc = CreateTemplateTupleDesc(NUM_PG_FILE_SETTINGS_ATTS, false);
***************
*** 8279,8285 **** show_all_file_settings(PG_FUNCTION_ARGS)
  	{
  		SRF_RETURN_DONE(funcctx);
  	}
- 
  }
  
  static char *
--- 8279,8284 ----

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: Fujii Masao <[email-masked]>
Date: Fri, 12 Jun 2015 13:00:07 +0900

> The patch also fixes two typos in comments related to pg_file_settings.

Applied.

Regards,

-- 
Fujii Masao

---

From: Stephen Frost <[email-masked]>
Date: Fri, 12 Jun 2015 09:45:26 -0400

> > The patch also fixes two typos in comments related to pg_file_settings.

Many thanks.  I had seen this and planned to do it, but happy that you
took care of it.

	Thanks again!

		Stephen