Subject: Two small doc fixes for config.sgml

From: Fujii Masao <[email-masked]>
Date: Mon, 20 Apr 2026 19:02:52 +0900

Hi,

I found two small issues in config.sgml and attached patches for both.

#1
The documentation for jit_debugging_support and jit_profiling_support says
these parameters can only be set at server start. However, both use
the PGC_SU_BACKEND context, which means they can be set at session start
by superusers or users with the appropriate SET privilege, but cannot be
changed within an active session. So, these descriptions should be corrected.
This fix should be backpatched to all supported versions.

#2
config.sgml describes the io_max_workers, io_worker_idle_timeout,
and io_worker_launch_interval GUCs as type "int". Elsewhere, config.sgml
consistently uses "integer" for this type. So those descriptions should be
updated to use "integer" for consistency.

Regards,

-- 
Fujii Masao
From a6810e7966e7e10df43c9da1687d9e183b9ab70c Mon Sep 17 00:00:00 2001
From: Fujii Masao <[email-masked]>
Date: Mon, 20 Apr 2026 17:54:50 +0900
Subject: [PATCH v1] doc: Correct context description for some JIT support GUCs

The documentation for jit_debugging_support and jit_profiling_support
previously stated that these parameters can only be set at server start.

However, both parameters use the PGC_SU_BACKEND context, meaning they
can be set at session start by superusers or users granted the appropriate
SET privilege, but cannot be changed within an active session.

This commit updates the documentation to reflect the actual behavior.

Backpatch to all supported versions.
---
 doc/src/sgml/config.sgml | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

diff --git a/doc/src/sgml/config.sgml b/doc/src/sgml/config.sgml
index d4bd981dfab..2308c87ca22 100644
--- a/doc/src/sgml/config.sgml
+++ b/doc/src/sgml/config.sgml
@@ -10978,7 +10978,8 @@ LOG:  CleanUpLock: deleting: lock(0xb7acd844) id(24688,24696,0,0,0,1)
         If LLVM has the required functionality, register generated functions
         with <productname>GDB</productname>.  This makes debugging easier.
         The default setting is <literal>off</literal>.
-        This parameter can only be set at server start.
+        Only superusers can change this parameter at session start,
+        and it cannot be changed at all within a session.
        </para>
       </listitem>
      </varlistentry>
@@ -11028,7 +11029,8 @@ LOG:  CleanUpLock: deleting: lock(0xb7acd844) id(24688,24696,0,0,0,1)
         This writes out files to <filename>~/.debug/jit/</filename>; the
         user is responsible for performing cleanup when desired.
         The default setting is <literal>off</literal>.
-        This parameter can only be set at server start.
+        Only superusers can change this parameter at session start,
+        and it cannot be changed at all within a session.
        </para>
       </listitem>
      </varlistentry>
-- 
2.53.0

---

From: Daniel Gustafsson <[email-masked]>
Date: Mon, 20 Apr 2026 12:13:00 +0200

> On 20 Apr 2026, at 12:02, Fujii Masao <[email-masked]> wrote:

> I found two small issues in config.sgml and attached patches for both.

Both fixes LGTM, confirmed that no other <type>int</type> exist (and double
checked if we had any bool/boolean but all seem to use boolean).

--
Daniel Gustafsson

---

From: Fujii Masao <[email-masked]>
Date: Tue, 21 Apr 2026 08:52:17 +0900

> checked if we had any bool/boolean but all seem to use boolean).

Thanks for the review! I've pushed the patches.

Regards,

-- 
Fujii Masao