Subject: pgtesttiming.sgml, FreeBSD command output

From: Josh Kupershmidt <[email-masked]>
Date: Fri, 6 Jul 2012 13:21:17 -0700

I noticed this little snippet claiming to be output on FreeBSD in
pgtesttiming.sgml:

<screen>
dmesg | grep "Timecounter"
sysctl kern.timecounter.hardware=TSC
</screen>

First, grep is case-sensitive by default, so that line of output
shouldn't have matched at all, right? Second, if I actually try the
above command on a FreeBSD 9 VM I have, I get (copying by hand, since
I can't seem to copy-and-paste out of this VM without X, please excuse
any typos):

Timecounter "ACPI-fast" frequency 3579545 Hz quality 900
Timecounter "i8254" frequency 1193182 Hz quality 0
Timecounters tick every 10.000 msec
Timecounter "TSC" frequency 2531787134 Hz quality 800

Anyway, if the original "sysctl ..." output is valid for a FreeBSD
machine, maybe only the grep command needs to be fixed (i.e. to "grep
-i ...") ?

Josh

---

From: Peter Eisentraut <[email-masked]>
Date: Fri, 06 Jul 2012 23:33:01 +0300

On fre, 2012-07-06 at 13:21 -0700, Josh Kupershmidt wrote:
> shouldn't have matched at all, right?

I don't think this was meant to say that the second line is the output
of the first.  I read this as two separate commands.  But I agree this
part is a bit unclear.

---

From: Josh Kupershmidt <[email-masked]>
Date: Fri, 6 Jul 2012 14:09:00 -0700

> of the first.  I read this as two separate commands.  But I agree this

Oh, I see now. The <screen> sections above and below that one were
including output, and I was just expecting the same here.

One way to fix would be to include shell prompts and outputs for both
commands (patch Option 1, attached).  Or, if we don't want to bother
including output, as the section does now, maybe we could at least
include the shell prompts and mention that output is excluded (patch
Option 2).

I've also attached an unrelated typofix I noticed for the same page.

Josh

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 30 Aug 2012 18:38:21 -0400

Patch attached and applied for PG 9.3.

---------------------------------------------------------------------------

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + It's impossible for everything to be true. +
diff --git a/doc/src/sgml/pgtesttiming.sgml b/doc/src/sgml/pgtesttiming.sgml
new file mode 100644
index 45ee80c..a2581d2
*** a/doc/src/sgml/pgtesttiming.sgml
--- b/doc/src/sgml/pgtesttiming.sgml
*************** Histogram of timing durations:
*** 183,190 ****
     information about the timer selected during boot:
  
  <screen>
! dmesg | grep "Timecounter"
! sysctl kern.timecounter.hardware=TSC
  </screen>
    </para>
  
--- 183,195 ----
     information about the timer selected during boot:
  
  <screen>
! # dmesg | grep "Timecounter"
! Timecounter "ACPI-fast" frequency 3579545 Hz quality 900
! Timecounter "i8254" frequency 1193182 Hz quality 0
! Timecounters tick every 10.000 msec
! Timecounter "TSC" frequency 2531787134 Hz quality 800
! # sysctl kern.timecounter.hardware=TSC
! kern.timecounter.hardware: ACPI-fast -> TSC
  </screen>
    </para>
  
*************** Histogram of timing durations:
*** 277,283 ****
    </para>
  
    <para>
!    Timers used on older PC hardware including the 8254 Programmable Interval
     Timer (PIT), the real-time clock (RTC), the Advanced Programmable Interrupt
     Controller (APIC) timer, and the Cyclone timer.  These timers aim for
     millisecond resolution.
--- 282,288 ----
    </para>
  
    <para>
!    Timers used on older PC hardware include the 8254 Programmable Interval
     Timer (PIT), the real-time clock (RTC), the Advanced Programmable Interrupt
     Controller (APIC) timer, and the Cyclone timer.  These timers aim for
     millisecond resolution.