Subject: Temporary tables and Write-Ahead Log

From: Víctor Herraiz Posada <[email-masked]>
Date: Sat, 18 Apr 2026 02:27:25 +0200

In create table documentation is not clear if temporary tables use the write-ahead log. Could you please add a sentence about that like in the unlogged tables?

---

From: "David G. Johnston" <[email-masked]>
Date: Sat, 18 Apr 2026 00:01:45 -0700

On Friday, April 17, 2026, Víctor Herraiz Posada <[email-masked]>
wrote:

> In create table documentation is not clear if temporary tables use the
> write-ahead log. Could you please add a sentence about that like in the
> unlogged tables?
>

The word “temporary” is communicating the entire first paragraph of what we
spell out in unlogged.

However, maybe I’d add to the end:

“Aside from the above, a temporary table behaves much like an unlogged
table - though a partitioned table consisting solely of temporary
partitions is allowed.”

David J.

---

From: Víctor Herraiz Posada <[email-masked]>
Date: Sat, 18 Apr 2026 15:40:22 +0200

Thank you David. I would be great to have that in the documents. I saw several “opinions” across internet.

El 18 abr 2026, a las 9:01, David G. Johnston <[email-masked]> escribió:

On Friday, April 17, 2026, Víctor Herraiz Posada <[email-masked]> wrote:

The word “temporary” is communicating the entire first paragraph of what we spell out in unlogged.

“Aside from the above, a temporary table behaves much like an unlogged table - though a partitioned table consisting solely of temporary partitions is allowed.”

David J.