Subject: glossary Data page

From: PG Doc comments form <[email-masked]>
Date: Mon, 29 Jun 2026 05:49:11 +0000

The following documentation comment has been logged on the website:

Page: https://www.postgresql.org/docs/18/glossary.html
Description:

> The basic structure used to store relation data. All pages are of the same
size. Data pages are typically stored on disk, each in a specific file, and
can be read to shared buffers where they can be modified, becoming dirty.
They become clean when written to disk. New pages, which initially exist in
memory only, are also dirty until written.

Am I correct in understanding from this description that all files on the
disk will be the same size?
One page = one file?

---

From: "David G. Johnston" <[email-masked]>
Date: Tue, 30 Jun 2026 06:28:39 -0700

> disk will be the same size?

No.  A page is an atomic unit subset of a file.  Files contain many pages.
It would be crazy to limit file sizes to 8kb when we have GB available.

David J.

---

From: Yaroslav Saburov <[email-masked]>
Date: Tue, 30 Jun 2026 18:04:53 +0300

Maybe these are just the intricacies of translation.
This is how I interpret it:

1) All pages are the same size.
2) Data pages are usually stored on disk,
3) each in a separate file, 

> 1) All pages are of the same size.
> 2) Data pages are typically stored on disk
> 3) each in a specific file,

> 30 черв. 2026 р. о 16:28 David G. Johnston <[email-masked]> пише:
> 
> On Sunday, June 28, 2026, PG Doc comments form <[email-masked]> wrote:
> No.  A page is an atomic unit subset of a file.  Files contain many pages.  It would be crazy to limit file sizes to 8kb when we have GB available.
> 
> David J.

---

From: "David G. Johnston" <[email-masked]>
Date: Tue, 30 Jun 2026 09:51:30 -0700

> > 3) each in a specific file,

More that the author is being imprecise here so as not to overwhelm
the reader with detail.

Patches are welcome, though at present I have no intent to write one.

David J.