Subject: glossary Delete

From: PG Doc comments form <[email-masked]>
Date: Mon, 29 Jun 2026 06:48:00 +0000

The following documentation comment has been logged on the website:

Page: https://www.postgresql.org/docs/18/glossary.html
Description:

> An SQL command which removes rows from a given table or relation.

but, glossary table :
> A table is the most common form of relation in PostgreSQL.

Why do you mean? Table OR relation. When a table is not a relation?

---

From: "David G. Johnston" <[email-masked]>
Date: Tue, 30 Jun 2026 06:32:43 -0700

> Why do you mean? Table OR relation. When a table is not a relation?

Deleting from an updatable view is possible…a relation that is not a
table.  It’s redundant to say table there but it’s not wrong; and pointing
out the table subset of “relations” seems reasonable.

David J.