public inbox for [email protected]
help / color / mirror / Atom feedFrom: David G. Johnston <[email protected]>
To: [email protected] <[email protected]>
To: [email protected] <[email protected]>
Subject: Re: Clarification on the (lack of) differences between the decimal, dec, and numeric types
Date: Thu, 12 Feb 2026 15:45:04 -0700
Message-ID: <CAKFQuwbszf7Z3CpTM2y3Z3XqX3VV90XR8ZD_DFnXv4O+TDwjUw@mail.gmail.com> (raw)
In-Reply-To: <[email protected]>
References: <[email protected]>
On Thursday, February 12, 2026, PG Doc comments form <[email protected]>
wrote:
>
>
> I suggest changing the wording of the page to read "decimal is an alias of
> the type numeric. Both reference the same underlying type."
>
I agree with the premise but would likely use a bit different wording and
also tweak the table at the top of the page. I’m disliking the idea of
calling something a data type if it doesn’t appear in pg_type; syntax
aliases should be called out for what they are. A nearby complaint
regarding nchar, which is also an alias but isn’t mentioned, informs this.
I do wonder what other “data type” aliases should be considered.
David J.
view thread (2+ messages)
reply
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: [email protected]
Cc: [email protected], [email protected], [email protected]
Subject: Re: Clarification on the (lack of) differences between the decimal, dec, and numeric types
In-Reply-To: <CAKFQuwbszf7Z3CpTM2y3Z3XqX3VV90XR8ZD_DFnXv4O+TDwjUw@mail.gmail.com>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox