Subject: Docs patch for REFRESH MATERIALIZED VIEW lock level

From: Craig Ringer <[email-masked]>
Date: Mon, 2 Nov 2015 09:58:33 +0800

The explicit locking docs mention the lock taken by REFRESH
MATERIALIZED VIEW CONCURRENTLY, but not plain REFRESH MATERIALIZED
VIEW. Patch.

-- 
 Craig Ringer                   http://www.2ndQuadrant.com/
 PostgreSQL Development, 24x7 Support, Training & Services
From d24f44836b6f7358fcea5c7d2aebf8a6522b6a41 Mon Sep 17 00:00:00 2001
From: Craig Ringer <[email-masked]>
Date: Mon, 2 Nov 2015 09:57:02 +0800
Subject: [PATCH] Mention lock level of REFRESH MATERIALIZED VIEW

---
 doc/src/sgml/mvcc.sgml | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/doc/src/sgml/mvcc.sgml b/doc/src/sgml/mvcc.sgml
index 5128982..396a5ba 100644
--- a/doc/src/sgml/mvcc.sgml
+++ b/doc/src/sgml/mvcc.sgml
@@ -990,7 +990,8 @@ ERROR:  could not serialize access due to read/write dependencies among transact
         <para>
          Acquired by the <command>DROP TABLE</>,
          <command>TRUNCATE</command>, <command>REINDEX</command>,
-         <command>CLUSTER</command>, and <command>VACUUM FULL</command>
+         <command>CLUSTER</command>, <command>VACUUM FULL</command>
+         and <command>REFRESH MATERIALIZED VIEW</command>
          commands. Many forms of <command>ALTER TABLE</> also acquire
          a lock at this level. This is also the default lock mode for
          <command>LOCK TABLE</command> statements that do not specify
-- 
2.1.0

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: Kevin Grittner <[email-masked]>
Date: Mon, 2 Nov 2015 13:05:54 +0000 (UTC)

> MATERIALIZED VIEW CONCURRENTLY, but not plain REFRESH MATERIALIZED

Pushed, with minor adjustment.

--
Kevin Grittner
EDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Craig Ringer <[email-masked]>
Date: Mon, 2 Nov 2015 21:58:30 +0800

> Pushed, with minor adjustment.

Thanks. I try to immediately write patches for small stuff like this,
otherwise it gets lost and forgotten again.