Subject: make html fails on a clean ubuntu

From: Idan Kamara <[email-masked]>
Date: Wed, 20 Apr 2016 20:48:14 -0700

Hi folks,

I'm trying to build the docs (at commit 9c75e1), but getting back a spew of
errors from `jade` (attached), which I'm having a hard time deciphering. I
did a clone from https://github.com/postgres/postgres and ran these
commands:

$ ./configure
$ cd doc/src/sgml
$ make html
<output attached>

Information about the system:

$ uname -a
Linux ubuntu-14 3.19.0-25-generic #26~14.04.1-Ubuntu SMP Fri Jul 24
21:16:20 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
$ jade -v
jade:I: Jade version "1.2.1"
jade:I: SP version "1.3.4"
jade:<OSFD>0:1:0:E: end of document in prolog
jade:E: no DSSSL specification: use -d to specify
$ make --version
GNU Make 3.81
Copyright (C) 2006  Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE.

This program built for x86_64-pc-linux-gnu
--

Did I miss anything obvious? Thanks.

-- 
Sent via pgsql-docs mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs

---

From: Tom Lane <[email-masked]>
Date: Thu, 21 Apr 2016 17:32:49 -0400

Idan Kamara <[email-masked]> writes:
> errors from `jade` (attached), which I'm having a hard time deciphering.

I think the relevant error is the first one:

> jade:postgres.sgml:3:55:W: cannot generate system identifier for public text "-//OASIS//DTD DocBook V4.2//EN"

You don't have the docbook DTD installed, I suspect.  There's some info
in our docs about which packages need to be installed to build the docs,
though I do not know if it's entirely up-to-date.

			regards, tom lane

---

From: Idan Kamara <[email-masked]>
Date: Thu, 21 Apr 2016 14:42:21 -0700

> though I do not know if it's entirely up-to-date.

Yeah, I think it's all here
http://www.postgresql.org/docs/9.5/static/docguide-toolsets.html

I hadn't seen that before and jumped directly to
http://www.postgresql.org/docs/9.5/static/docguide-build.html

Thanks.

---

From: Peter Eisentraut <[email-masked]>
Date: Fri, 22 Apr 2016 11:52:36 -0400

> though I do not know if it's entirely up-to-date.

The instructions ought to be reasonably up to date for Ubuntu.

I think you might be missing the DocBook package.  Check the end of the
configure output about what it has or hasn't found.