Subject: DOCS: SGML identifier may not exceed 44 characters

From: Brendan Jurd <[email-masked]>
Date: Tue, 31 May 2011 16:17:22 +1000

Hi folks,

I was working on a little docs patch today, and when I tried to
`make`, openjade choked on an identifier in information_schema.sgml,
which is very much unrelated to my changes:

openjade:information_schema.sgml:828:60:Q: length of name token must
not exceed NAMELEN (44)

Here is a trivial patch to shut openjade up.  This particular id does
not appear to be referred to anywhere else in the docs yet.

The identifier appears to have been introduced in commit
2e2d56fea97f43cf8c40a87143bc10356e4ed4d4 on Feb 9 this year.

I'm using openjade 1.3.2.

Cheers,
BJ

diff --git a/doc/src/sgml/information_schema.sgml
b/doc/src/sgml/information_schema.sgml
index 2febb4c..5fdbd51 100644
--- a/doc/src/sgml/information_schema.sgml
+++ b/doc/src/sgml/information_schema.sgml
@@ -825,7 +825,7 @@
   </table>
  </sect1>

- <sect1 id="infoschema-collation-character-set-applicability">
+ <sect1 id="infoschema-collation-charset-applicability">
   <title><literal>collation_character_set_applicability</literal></title>

   <para>

---

From: Alvaro Herrera <[email-masked]>
Date: Tue, 31 May 2011 11:22:52 -0400

> openjade:information_schema.sgml:828:60:Q: length of name token must

Odd.  I tried it here and it doesn't fail -- same openjade version.
Maybe mine is patched.

-- 
Álvaro Herrera <[email-masked]>
The PostgreSQL Company - Command Prompt, Inc.
PostgreSQL Replication, Consulting, Custom Development, 24x7 support

---

From: Christopher Browne <[email-masked]>
Date: Tue, 31 May 2011 15:52:32 +0000

> Odd.  I tried it here and it doesn't fail -- same openjade version.

It's not likely an issue of how OpenJade was compiled; there has been
a limitation in how SGML parsing was configured.  If you poke around
in /usr/share/sgml, you should find some configuration indicating
NAMELEN was set to 44.

I recall hearing that this was an issue in older Red Hat and
derivative distributions, and thought that it was supposed to be
resolved several years ago, but perhaps there's something to undermine
that belief.

At any rate, I'd suggest grepping around for NAMELEN in
/usr/share/sgml; you'll likely see a limitation there, in some SGML
configuration file.
-- 
When confronted by a difficult problem, solve it by reducing it to the
question, "How would the Lone Ranger handle this?"

---

From: Tom Lane <[email-masked]>
Date: Tue, 31 May 2011 12:13:35 -0400

> in /usr/share/sgml, you should find some configuration indicating

On a Fedora 13 machine:

$ grep -r NAMELEN /usr/share/sgml/
/usr/share/sgml/openjade-1.3.2/style-sheet.dtd:  ArcQuant CDATA #FIXED "NAMELEN 64"
/usr/share/sgml/docbook/sgml-dtd-3.0-1.0-50.fc13/docbook.dcl:           NAMELEN    256
/usr/share/sgml/docbook/sgml-dtd-3.0-1.0-50.fc13/cals-tbl.dtd:     NOTE:  This set of declarations assumes a NAMELEN of 32 as is used in
/usr/share/sgml/docbook/sgml-dtd-4.4-1.0-50.fc13/docbook.dcl:           NAMELEN    256
/usr/share/sgml/docbook/dsssl-stylesheets/dtds/dbdsssl/dbdsssl.dtd:  ArcQuant CDATA #FIXED "NAMELEN 64"
/usr/share/sgml/docbook/dsssl-stylesheets/dtds/decls/docbook.dcl:               NAMELEN    44
/usr/share/sgml/docbook/sgml-dtd-3.1-1.0-50.fc13/docbook.dcl:           NAMELEN    256
/usr/share/sgml/docbook/sgml-dtd-3.1-1.0-50.fc13/cals-tbl.dtd:     NOTE:  This set of declarations assumes a NAMELEN of 32 as is used in
/usr/share/sgml/docbook/sgml-dtd-4.1-1.0-50.fc13/docbook.dcl:           NAMELEN    256
/usr/share/sgml/docbook/sgml-dtd-4.1-1.0-50.fc13/cals-tbl.dtd:     NOTE:  This set of declarations assumes a NAMELEN of 32 as is used in
/usr/share/sgml/docbook/sgml-dtd-4.2-1.0-50.fc13/docbook.dcl:           NAMELEN    256
/usr/share/sgml/docbook/sgml-dtd-4.5-1.0-50.fc13/docbook.dcl:           NAMELEN    256
/usr/share/sgml/docbook/dsssl-stylesheets-1.79/dtds/dbdsssl/dbdsssl.dtd:  ArcQuant CDATA #FIXED "NAMELEN 64"
/usr/share/sgml/docbook/dsssl-stylesheets-1.79/dtds/decls/docbook.dcl:          NAMELEN    44
/usr/share/sgml/docbook/sgml-dtd-4.3-1.0-50.fc13/docbook.dcl:           NAMELEN    256
/usr/share/sgml/docbook/sgml-dtd-4.0-1.0-50.fc13/docbook.dcl:           NAMELEN    256
/usr/share/sgml/docbook/sgml-dtd-4.0-1.0-50.fc13/cals-tbl.dtd:     NOTE:  This set of declarations assumes a NAMELEN of 32 as is used in
/usr/share/sgml/html.dcl:                  NAMELEN  72    -- somewhat arbitrary; taken from

It's hard to tell from this exactly which value is active in what
contexts, but it does look like 44 is relevant in some.  FWIW,
I don't see the reported failure on this machine ...

			regards, tom lane

---

From: Peter Eisentraut <[email-masked]>
Date: Tue, 31 May 2011 23:36:10 +0300

> I don't see the reported failure on this machine ...

It looks like the original DocBook distribution has a limit of 44, but
someone patched it to 256 on your installation.

But it seems like no one else has seen this problem yet, so it's quite
suspicious, since surely people have built the documentation in the last
few months.

---

From: Andrew Dunstan <[email-masked]>
Date: Tue, 31 May 2011 17:21:58 -0400

> suspicious, since surely people have built the documentation in the last

I have two buildfarm members with stock openjade/docbook installations 
building the docs every day.

cheers

andrew

---

From: Brendan Jurd <[email-masked]>
Date: Wed, 1 Jun 2011 11:05:39 +1000

> suspicious, since surely people have built the documentation in the last

The relevant value on my machine seems to be:

/usr/share/sgml/docbook/sgml-dtd-4.2/docbook.dcl:81:          NAMELEN    44

This file belongs to the Gentoo package app-text/docbook-sgml-dtd
4.2-r2, which is the current stable version for the 4.2 slot.

I would hazard to suggest that nobody else is seeing this problem
because I'm the only one building the docs on Gentoo =)

Still, the 44 character limit does seem to be per the upstream
distribution, and the identifier I patched above is the first one to
violate it.  Are there any solid reasons we shouldn't just comply with
it?

Cheers,
BJ

---

From: "Albe Laurenz" <[email-masked]>
Date: Wed, 1 Jun 2011 09:31:36 +0200

> suspicious, since surely people have built the documentation in the last

I have and I encountered the same problem.
I didn't bother to report it because my machine and openjade are quite old:

The machine is Red Hat Enterprise Linux ES release 3 (Taroon Update 9),
and docbook.dcl is from the docbook-dtds-1.0-17.2 RPM.

Maybe that really only affects quite old versions, but I think it wouldn't
hurt to shorten the tag in question to avoid the problem.

Yours,
Laurenz Albe

---

From: Robert Haas <[email-masked]>
Date: Wed, 1 Jun 2011 12:55:21 -0400

> hurt to shorten the tag in question to avoid the problem.

+1.

-- 
Robert Haas
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

---

From: Andrew Dunstan <[email-masked]>
Date: Wed, 01 Jun 2011 13:19:53 -0400

On 06/01/2011 12:55 PM, Robert Haas wrote:
> On Wed, Jun 1, 2011 at 3:31 AM, Albe Laurenz<[email-masked]>  wrote:
>> Peter Eisentrautwrote:

Is there no way we can ourselves override this setting if we run into 
it? If it's possible that seems to me like a much better way to go.

cheers

andrew

---

From: Peter Eisentraut <[email-masked]>
Date: Fri, 03 Jun 2011 22:26:13 +0300

> openjade:information_schema.sgml:828:60:Q: length of name token must

Fixed.