Subject: Volunteering

From: "[email-masked]" <[email-masked]>
Date: Fri, 12 Dec 2025 15:47:33 +0000

Hello,

My name is Grant Fritchey. I'm very interested in contributing to the PostgreSQL project. However, I'm just a DBA, so I won't be writing a lot of code with the Hackers. However, I can write, so I'd be interested in volunteering with the documentation team. Could someone share the general duties & needs and just how I'd go about getting involved please?

Thanks,

Grant

---

From: Laurenz Albe <[email-masked]>
Date: Fri, 12 Dec 2025 21:07:18 +0100

On Fri, 2025-12-12 at 15:47 +0000, [email-masked] wrote:
> My name is Grant Fritchey. I'm very interested in contributing to the PostgreSQL project.
> However, I'm just a DBA, so I won't be writing a lot of code with the Hackers.
> However, I can write, so I'd be interested in volunteering with the documentation team.
> Could someone share the general duties & needs and just how I'd go about getting involved please?

Welcome!

I'd start by reading appendix J of the documentation.
Set up a build environment for the documentation.

Even if you don't want to write source code, much of the information in
this article will still apply:
https://wiki.postgresql.org/wiki/So,_you_want_to_be_a_developer%3F

Get familiar with the commitfest app: https://commitfest.postgresql.org/
Patches that you want to be reviewed and committed should go there.
The best starting point might be to review some documentation patches
from the next commitfest.

I am not aware of a TODO list for the documentation, so if you don't
have your own ideas about improving the documentation, you can hang out
on the -docs mailing list and read the questions and complaints that
others have.

Yours,
Laurenz Albe

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 15 Dec 2025 13:58:17 +0000

Cheers!

Appreciate the info. I'll be reading and watching for the moment.
________________________________
From: Laurenz Albe <[email-masked]>
Sent: Friday, December 12, 2025 2:07 PM
To: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: Volunteering

Welcome!

Yours,
Laurenz Albe