Subject: Re: [DOCS] [BUGS] BUG #1414: DOC - pl/Perl hash tags

From: Alexey Borzov <[email-masked]>
Date: Fri, 21 Jan 2005 00:28:44 +0300

Hi,

Magnus Hagander wrote:
>>>In the pl/Perl section of the 8.0.0 manual, as viewed on the 
>>
>>postgresql.org
>>
>>>web site, all perl code hash tags seem to be missing.  i.e. 
>>
>>Yeah, I see the same; but it's not in the devel docs.  Compare
>>	http://www.postgresql.org/docs/8.0/static/plperl.html
>>	http://developer.postgresql.org/docs/postgres/plperl.html
>>and look for instance at the empcomp() function about halfway down
>>the page:
>>   return $emp-> + $emp->;
>>vs
>>   return $emp->{basesalary} + $emp->{bonus};
>>
>>Any theories what's wrong here?
> 
> 
> Going out on a line a bit here - and someone who've worked with teh
> system probably knows for sure but... It looks like {} is used as the
> template placeholder in the templating system on the website.

Yes, that's exactly the case...

> It would seem to me that the fix would be as simple as to set
> $removeUnknownVariables to false when parsing the docs template, but I'm
> far from sure at that. And I have no way to test it. And it might break
> something else. End of disclaimers.

The clean solution would be to use
$tpl->setOption('preserve_data', true);

In this case there will be no problems even if a known placeholder appears in 
the docs.

Sorry, cannot fix it myself right now, don't want to checkout the website code 
as there is a sh*tload of PDF docs in there.

---

From: "Dave Page" <[email-masked]>
Date: Fri, 21 Jan 2005 08:30:16 -0000

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Alexey Borzov
> Sent: 20 January 2005 21:29
> To: Magnus Hagander
> Cc: Tom Lane; Mike Blackwell; [email-masked]; 
> [email-masked]
> Subject: Re: [pgsql-www] [DOCS] [BUGS] BUG #1414: DOC - 
> pl/Perl hash tags
> 

Thanks Alexey - fixed in CVS, next docs regen is in about 20 hours.

/D