Subject: NetBSD kernel resource configuration

From: Kris Jurka <[email-masked]>
Date: Fri, 17 Jun 2005 02:00:49 -0500 (EST)

The documentation describing NetBSD kernel configuration mentions that it 
uses the "option" keyword like OpenBSD, but in fact it uses the "options" 
keyword like FreeBSD.

http://developer.postgresql.org/docs/postgres/kernel-resources.html#SYSVIPC

http://cvsweb.netbsd.org/bsdweb.cgi/src/sys/arch/i386/conf/GENERIC?rev=1.674&content-type=text/x-cvsweb-markup

Kris Jurka

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 17 Jun 2005 09:11:36 -0400 (EDT)

> http://cvsweb.netbsd.org/bsdweb.cgi/src/sys/arch/i386/conf/GENERIC?rev=1.674&content-type=text/x-cvsweb-markup

Fix applied.  Thanks.  This problem doesn't appear in the 8.0.X docs.

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073
Index: doc/src/sgml/runtime.sgml
===================================================================
RCS file: /cvsroot/pgsql/doc/src/sgml/runtime.sgml,v
retrieving revision 1.327
diff -c -c -r1.327 runtime.sgml
*** doc/src/sgml/runtime.sgml	17 Jun 2005 03:25:51 -0000	1.327
--- doc/src/sgml/runtime.sgml	17 Jun 2005 13:04:21 -0000
***************
*** 4544,4551 ****
         <para>
          <systemitem class="osname">FreeBSD</> versions before 4.0 work like 
          <systemitem class="osname">NetBSD</> and <systemitem class="osname">
!         OpenBSD</> (see below), except that the configuration file uses the 
!         keyword "options" instead of "option".
         </para>
        </listitem>
       </varlistentry>
--- 4544,4550 ----
         <para>
          <systemitem class="osname">FreeBSD</> versions before 4.0 work like 
          <systemitem class="osname">NetBSD</> and <systemitem class="osname">
!         OpenBSD</> (see below).
         </para>
        </listitem>
       </varlistentry>
***************
*** 4561,4577 ****
          to be enabled when the kernel is compiled. (They are by
          default.) The maximum size of shared memory is determined by
          the option <varname>SHMMAXPGS</> (in pages). The following
!         shows an example of how to set the various parameters:
  <programlisting>
! option         SYSVSHM
! option         SHMMAXPGS=4096
! option         SHMSEG=256
! 
! option         SYSVSEM
! option         SEMMNI=256
! option         SEMMNS=512
! option         SEMMNU=256
! option         SEMMAP=256
  </programlisting>
         </para>
  
--- 4560,4577 ----
          to be enabled when the kernel is compiled. (They are by
          default.) The maximum size of shared memory is determined by
          the option <varname>SHMMAXPGS</> (in pages). The following
!         shows an example of how to set the various parameters 
!         (<systemitem class="osname">OpenBSD</> uses <literal>option</> instead):
  <programlisting>
! options        SYSVSHM
! options        SHMMAXPGS=4096
! options        SHMSEG=256
! 
! options        SYSVSEM
! options        SEMMNI=256
! options        SEMMNS=512
! options        SEMMNU=256
! options        SEMMAP=256
  </programlisting>
         </para>

---

From: Kris Jurka <[email-masked]>
Date: Fri, 17 Jun 2005 11:00:04 -0500 (EST)

> Fix applied.  Thanks.  This problem doesn't appear in the 8.0.X docs.

It does, but in a slightly different form.  It says "(On NetBSD and 
OpenBSD the key word is actually option singular.)"

Kris Jurka

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 17 Jun 2005 12:46:22 -0400 (EDT)

Oh, thanks.  Fixed in 8.0.X.

---------------------------------------------------------------------------

Kris Jurka wrote:
> ---------------------------(end of broadcast)---------------------------
> TIP 1: subscribe and unsubscribe commands go to [email-masked]
> 

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073
Index: doc/src/sgml/runtime.sgml
===================================================================
RCS file: /cvsroot/pgsql/doc/src/sgml/runtime.sgml,v
retrieving revision 1.301.4.6
diff -c -c -r1.301.4.6 runtime.sgml
*** doc/src/sgml/runtime.sgml	9 May 2005 17:26:55 -0000	1.301.4.6
--- doc/src/sgml/runtime.sgml	17 Jun 2005 16:45:05 -0000
***************
*** 4375,4382 ****
  options         SEMMNU=256
  options         SEMMAP=256
  </programlisting>
!         (On <systemitem class="osname">NetBSD</> and <systemitem
!         class="osname">OpenBSD</> the key word is actually
          <literal>option</literal> singular.)
         </para>
         <para>
--- 4375,4381 ----
  options         SEMMNU=256
  options         SEMMAP=256
  </programlisting>
!         (On <systemitem class="osname">OpenBSD</> the key word is actually
          <literal>option</literal> singular.)
         </para>
         <para>