Subject: Suggestion

From: muhammad umar <[email-masked]>
Date: Mon, 31 Mar 2003 02:50:02 -0800 (PST)

hello,
im using PostgreSQL 7.3.1 on i686-pc-linux-gnu,
compiled by GCC 2.96.
i have a suggestion for the name of this DBMS, and
that it should not be PostgreSQL but it should be
PregreSQL, as im feeling its a DBMS that perhaps might
be used 100 years ago,,proof for this is its
techniques for showing errors that if we have a 1400
lines sql query contain some error,,it give error as "
parse error at or near <some column name>" ,,now if
that column is used at several places ,,we might have
to browse the whole of the cream.......
this is one of example of the limit of stupidity this
DBMS having,,,
this used to waste the time that should be spent in
development...so consider changing the name of this
stupid DBMS,,

regards
Muhammad Umar Liaquat
Database Administrator
Vigilant Systems Limited.

__________________________________________________
Do you Yahoo!?
Yahoo! Platinum - Watch CBS' NCAA March Madness, live on your desktop!
http://platinum.yahoo.com

---

From: "scott.marlowe" <[email-masked]>
Date: Thu, 3 Apr 2003 11:08:28 -0700 (MST)

> development...so consider changing the name of this

Two suggestions:

1:  No one is twisting your arm, feel free to switch to something else.
2:  Patches happily accepted.

---

From: Darren Ferguson <[email-masked]>
Date: Thu, 03 Apr 2003 13:27:56 -0500

The database parser in 7.3.2 tells you the character at which the error 
occurred. You could always upgrade to that version instead of bumping 
your gums on a topic where people spend there own free time providing a 
system for you to use.

Have some consideration
Darren

muhammad umar wrote:

>---------------------------(end of broadcast)---------------------------
>TIP 3: if posting/reading through Usenet, please send an appropriate
>subscribe-nomail command to [email-masked] so that your
>message can get through to the mailing list cleanly
>  
>

---

From: Ericson Smith <[email-masked]>
Date: 03 Apr 2003 13:31:42 -0500

Muhammad,

The postgresql list is one that is well known for politeness and
courtesy above all.

For instance, someone today requested information about MySQL, and one
of the members was kind enough to do research for him and to even post a
link to where the person could find the information.

My point is, if you need help, we will be more than happy to give it, no
matter how long it takes. Many times people on the list have saved my
bacon with friendly and courteous advice time after time. Even the
response by Scott to you was courteous and helpful.

- Ericson Smith
[email-masked]
http://www.did-it.com

-- 
Ericson Smith <[email-masked]>

---

From: Dennis Gearon <[email-masked]>
Date: Thu, 03 Apr 2003 10:38:25 -0800

maybe he's a little vitrolic, but the error reporting could be MUCH better. 
Seems like the parse tree should be able to show where the error is.

---

From: Dennis Gearon <[email-masked]>
Date: Thu, 03 Apr 2003 11:16:55 -0800

I stand corrected, after reading tom's post about 7.3.2.

Error reporting to the point of failure in the querry is COOL, thanks to all who 
worked on that. I will have to bug my provider to install the latest version.

Dennis Gearon wrote:
> maybe he's a little vitrolic, but the error reporting could be MUCH 
> better. Seems like the parse tree should be able to show where the error 
> is.
> 
> muhammad umar wrote:
> 
>> hello,
> TIP 5: Have you checked our extensive FAQ?
> 
> http://www.postgresql.org/docs/faqs/FAQ.html
>