Subject: Add cross-references re schema search path

From: Oliver Elphick <[email-masked]>
Date: 20 Aug 2002 06:49:45 +0100

I had great difficulty in finding how to change the search path, so here
is a patch to add some cross-referencing.

-- 
Oliver Elphick                                [email-masked]
Isle of Wight, UK                            
http://www.lfix.co.uk/oliver
GPG: 1024D/3E1D0C1C: CA12 09E0 E8D5 8870 5839  932A 614D 4C34 3E1D 0C1C
                 ========================================
     "But I would not have you to be ignorant, brethren, 
      concerning them which are asleep, that ye sorrow not, 
      even as others which have no hope. For if we believe 
      that Jesus died and rose again, even so them also 
      which sleep in Jesus will God bring with him."        
                                I Thessalonians 4:13,14 
Index: doc/src/sgml/func.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql-server/doc/src/sgml/func.sgml,v
retrieving revision 1.112
diff -u -r1.112 func.sgml
--- doc/src/sgml/func.sgml	2002/08/16 23:01:18	1.112
+++ doc/src/sgml/func.sgml	2002/08/19 04:15:18
@@ -5139,6 +5139,11 @@
     path returned.
    </para>
 
+   <para>
+    The search path may be altered by a runtime-alterable GUC setting:
+    <xref linkend="set-search-path">.
+   </para>
+
    <table>
     <title>System Information Functions</title>
     <tgroup cols="3">
Index: doc/src/sgml/runtime.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql-server/doc/src/sgml/runtime.sgml,v
retrieving revision 1.126
diff -u -r1.126 runtime.sgml
--- doc/src/sgml/runtime.sgml	2002/08/18 03:03:25	1.126
+++ doc/src/sgml/runtime.sgml	2002/08/19 04:15:23
@@ -1548,7 +1548,7 @@
       </listitem>
      </varlistentry>
 
-     <varlistentry>
+     <varlistentry id="set-search-path" xreflabel="SET SEARCH_PATH">
       <term><varname>SEARCH_PATH</varname> (<type>string</type>)</term>
       <indexterm><primary>search_path</></>
       <indexterm><primary>namespaces</></>
@@ -1608,6 +1608,10 @@
        </para>
 
        <para>
+	 <indexterm>
+	  <primary>schemas</primary>
+	  <secondary>current schema</secondary>
+	 </indexterm>
         The current effective value of the search path can be examined
 	via the SQL function <function>current_schemas()</>.  This is not
 	quite the same as examining the value of
Index: doc/src/sgml/syntax.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql-server/doc/src/sgml/syntax.sgml,v
retrieving revision 1.66
diff -u -r1.66 syntax.sgml
--- doc/src/sgml/syntax.sgml	2002/08/13 20:40:43	1.66
+++ doc/src/sgml/syntax.sgml	2002/08/19 04:15:36
@@ -965,6 +965,11 @@
     place <literal>pg_catalog</> at the end of your search path if you
     prefer to have user-defined names override built-in names.
    </para>
+
+    <para>
+     The search path is determined by the GUC variable SEARCH_PATH and
+     may be changed at any time.  See <xref linkend="set-search-path">.
+    </para>
   </sect2>
 
   <sect2 id="sql-reserved-names">

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 20 Aug 2002 16:07:54 -0400 (EDT)

Your patch has been added to the PostgreSQL unapplied patches list at:

	http://candle.pha.pa.us/cgi-bin/pgpatches

I will try to apply it within the next 48 hours.

---------------------------------------------------------------------------

> is a patch to add some cross-referencing.

[ text/x-patch is unsupported, treating like TEXT/PLAIN ]

> 
> ---------------------------(end of broadcast)---------------------------
> TIP 5: Have you checked our extensive FAQ?
> 
> http://www.postgresql.org/users-lounge/docs/faq.html

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073

---

From: Peter Eisentraut <[email-masked]>
Date: Tue, 20 Aug 2002 23:20:56 +0200 (CEST)

> is a patch to add some cross-referencing.

You can't link across books.  They need to build separately.

-- 
Peter Eisentraut   [email-masked]

---

From: Bruce Momjian <[email-masked]>
Date: Tue, 20 Aug 2002 17:24:04 -0400 (EDT)

OK, I will remove the reference to:

                                                 ^^^^^^^^^^^^^^^^^^^^^^^^^^

Peter Eisentraut wrote:
> TIP 6: Have you searched our list archives?
> 
> http://archives.postgresql.org
>

---

From: Oliver Elphick <[email-masked]>
Date: 21 Aug 2002 22:55:18 +0100

> You can't link across books.  They need to build separately.

Here's a replacement patch.
  
-- 
Oliver Elphick                                [email-masked]
Isle of Wight, UK                            
http://www.lfix.co.uk/oliver
GPG: 1024D/3E1D0C1C: CA12 09E0 E8D5 8870 5839  932A 614D 4C34 3E1D 0C1C
                 ========================================
     "But I would not have you to be ignorant, brethren, 
      concerning them which are asleep, that ye sorrow not, 
      even as others which have no hope. For if we believe 
      that Jesus died and rose again, even so them also 
      which sleep in Jesus will God bring with him."        
                                I Thessalonians 4:13,14 
Index: doc/src/sgml/func.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql-server/doc/src/sgml/func.sgml,v
retrieving revision 1.115
diff -u -r1.115 func.sgml
--- doc/src/sgml/func.sgml	2002/08/21 16:08:19	1.115
+++ doc/src/sgml/func.sgml	2002/08/21 21:47:19
@@ -5144,6 +5144,17 @@
     path returned.
    </para>
 
+   <para id=set-search-path xreflabel="SET SEARCH_PATH">
+    <indexterm>
+     <primary>search path</primary>
+     <secondary>changing at runtime</secondary>
+    </indexterm>
+    The search path may be altered by a runtime-alterable GUC setting.  The
+    command to use is <command>
+     SET SEARCH_PATH '<varname>schema</varname>'[,'<varname>schema</varname>']...
+    </command>
+   </para>
+
    <table>
     <title>System Information Functions</title>
     <tgroup cols="3">
Index: doc/src/sgml/runtime.sgml
===================================================================
RCS file: /projects/cvsroot/pgsql-server/doc/src/sgml/runtime.sgml,v
retrieving revision 1.126
diff -u -r1.126 runtime.sgml
--- doc/src/sgml/runtime.sgml	2002/08/18 03:03:25	1.126
+++ doc/src/sgml/runtime.sgml	2002/08/21 21:47:23
@@ -1608,6 +1608,10 @@
        </para>
 
        <para>
+	 <indexterm>
+++ doc/src/sgml/syntax.sgml	2002/08/21 21:47:37

---

From: Bruce Momjian <[email-masked]>
Date: Wed, 21 Aug 2002 18:04:11 -0400 (EDT)

> TIP 3: if posting/reading through Usenet, please send an appropriate
> subscribe-nomail command to [email-masked] so that your
> message can get through to the mailing list cleanly

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 22 Aug 2002 00:52:04 -0400 (EDT)

Patch applied.  Thanks.