Subject: Clarification in create_function.sgml

From: Oliver Elphick <[email-masked]>
Date: Tue, 21 Oct 2003 11:13:32 +0100

It is necessary for single quotes and backslashes in a function
definition to be escaped, but the reference page does not make this
clear. 

diff -c -r1.52 create_function.sgml
*** create_function.sgml        11 Sep 2003 21:42:20 -0000      1.52
--- create_function.sgml        21 Oct 2003 10:10:08 -0000
***************
*** 252,257 ****
--- 252,261 ----
         language.  It may be an internal function name, the path to an
         object file, an SQL command, or text in a procedural language.
        </para>
+       <para>
+        Any single quotes or backslashes in the function definition must be
+        escaped by doubling them.
+       </para>
       </listitem>
      </varlistentry>

-- 
Oliver Elphick                                [email-masked]
Isle of Wight, UK                             http://www.lfix.co.uk/oliver
GPG: 1024D/3E1D0C1C: CA12 09E0 E8D5 8870 5839  932A 614D 4C34 3E1D 0C1C
                 ========================================
     "If ye then be risen with Christ, seek those things 
      which are above, where Christ sitteth on the right 
      hand of God. Set your affection on things above, not 
      on things on the earth."              Colossians 3:1,2

---

From: Peter Eisentraut <[email-masked]>
Date: Tue, 21 Oct 2003 18:42:54 +0200 (CEST)

> definition to be escaped, but the reference page does not make this

This ought to be implicit in it being a string literal.

-- 
Peter Eisentraut   [email-masked]

---

From: Oliver Elphick <[email-masked]>
Date: Tue, 21 Oct 2003 17:46:07 +0100

> This ought to be implicit in it being a string literal.

Yes, but people sometimes need to have things spelt out.

It took a fairly lengthy correspondence to convince one bug reporter
that there was no bug; spelling it out for him in the reference would
have helped.

---

From: Tom Lane <[email-masked]>
Date: Tue, 21 Oct 2003 12:48:13 -0400

> This ought to be implicit in it being a string literal.

It is mentioned in many places, but not on that particular page.

I don't have a problem with adding something there too, but I think it
ought to go in the NOTES section rather than where Oliver has put it.
We commonly have "Don't forget that ..." kinds of items in NOTES.

			regards, tom lane

---

From: Josh Berkus <[email-masked]>
Date: Tue, 21 Oct 2003 09:51:33 -0700

Oliver, Peter,

> that there was no bug; spelling it out for him in the reference would

+1; we need things spelled out.

-- 
Josh Berkus
Aglio Database Solutions
San Francisco

---

From: Bruce Momjian <[email-masked]>
Date: Sun, 26 Oct 2003 00:34:19 -0400 (EDT)

I have added this to the CREATE FUNCTION manual page, in the notes
section.

---------------------------------------------------------------------------

Oliver Elphick wrote:
> ---------------------------(end of broadcast)---------------------------
> TIP 4: Don't 'kill -9' the postmaster
> 

-- 
  Bruce Momjian                        |  http://candle.pha.pa.us
  [email-masked]               |  (610) 359-1001
  +  If your life is a hard drive,     |  13 Roberts Road
  +  Christ can be your backup.        |  Newtown Square, Pennsylvania 19073