Subject: Quick help with CVS?

From: Josh Berkus <[email-masked]>
Date: Wed, 22 Oct 2003 14:49:27 -0700

Folks,

I can't seem to find the CVS command for telling a single file to revert to 
the version in the repository.  Help?

-- 
-Josh Berkus
 Aglio Database Solutions
 San Francisco

---

From: Peter Eisentraut <[email-masked]>
Date: Thu, 23 Oct 2003 00:03:51 +0200 (CEST)

> the version in the repository.  Help?

It would normally be cvs update -A filename, but the postgresql.org CVS
server doesn't support this.  So I suggest 'rm && cvs update'.

-- 
Peter Eisentraut   [email-masked]

---

From: Roberto Mello <[email-masked]>
Date: Wed, 22 Oct 2003 16:08:45 -0600

> the version in the repository.  Help?

If you don't care about yor modifications, you can just rm the file then
"cvs update -Pd" to re-add it from the repository.

There are other ways too. See the CVS red book (available online).

-Roberto

-- 
+----|        Roberto Mello   -    http://www.brasileiro.net/  |------+
+       Computer Science Graduate Student, Utah State University      +
+       USU Free Software & GNU/Linux Club - http://fslc.usu.edu/     +
:.:..::..:::.:::::..:..:.:..:..::::.:...:: => BRAILE TAGLINE!

---

From: "Marc G. Fournier" <[email-masked]>
Date: Wed, 22 Oct 2003 21:16:35 -0300 (ADT)

> It would normally be cvs update -A filename, but the postgresql.org CVS

Huh?  Works for me:

%cvs update -rREL7_4_BETA4 HISTORY
U HISTORY
%cvs status HISTORY
===================================================================
File: HISTORY           Status: Up-to-date

   Working revision:    1.219   Thu Oct 23 00:16:19 2003
   Repository revision: 1.219   /cvsroot/pgsql-server/HISTORY,v
   Sticky Tag:          REL7_4_BETA4 (revision: 1.219)
   Sticky Date:         (none)
   Sticky Options:      (none)

%cvs update -A HISTORY
U HISTORY
%cvs status HISTORY
===================================================================
File: HISTORY           Status: Up-to-date

   Working revision:    1.222   Thu Oct 23 00:16:29 2003
   Repository revision: 1.222   /cvsroot/pgsql-server/HISTORY,v
   Sticky Tag:          (none)
   Sticky Date:         (none)
   Sticky Options:      (none)