Subject: DocBook V4.2, on the way to XML

From: Peter Eisentraut <[email-masked]>
Date: Mon, 24 Nov 2003 20:20:51 +0100 (CET)

I've upgraded our documentation to DocBook V4.2 SGML.  I was able to
install 4.2 by going to http://www.docbook.org/sgml/4.2/, unzipping the
file in a suitable place and adding the docbook.cat file to the
environment variable SGML_CATALOG_FILES.  Packages are also available for
several operating systems.  If you have trouble installing or using 4.2,
please post it here.

The next step will be to create an XSLT stylesheet customization layer
that results in equivalent output to our current DSSSL setup.  Once that
is available, we can switch to XML.

-- 
Peter Eisentraut   [email-masked]

---

From: Tom Lane <[email-masked]>
Date: Mon, 24 Nov 2003 16:30:59 -0500

Peter Eisentraut <[email-masked]> writes:
> I've upgraded our documentation to DocBook V4.2 SGML.

The developer docs build seems busted ...
http://developer.postgresql.org/docs/postgres/buildlog.html

			regards, tom lane

---

From: Halley Pacheco de Oliveira<[email-masked]>
Date: Mon, 24 Nov 2003 18:46:36 -0300 (ART)

Dear Peter,

Please tell me from where I can download this upgraded
documentation so I can try by myself.

Thanks,
Halley

> > I've upgraded our documentation to DocBook V4.2

______________________________________________________________________

Yahoo! Mail: 6MB, anti-spam e antivírus gratuito! Crie sua conta agora:
http://mail.yahoo.com.br

---

From: Peter Eisentraut <[email-masked]>
Date: Mon, 24 Nov 2003 22:51:03 +0100 (CET)

> documentation so I can try by myself.

It's in the CVS repository, but there is nothing exciting in there that's
worth trying out.

---

From: Halley Pacheco de Oliveira<[email-masked]>
Date: Tue, 25 Nov 2003 06:05:35 -0300 (ART)

Dear Peter,

There is one very exciting thing in there. I
downloaded the upgraded documentation from the CVS
repository and I could generate the documentation
using RedHat 9.0 without having to install or
configure anything. The 'gmake all' just worked fine
and produced the HTML files.

***  This is the definition of DocBook itself. We
currently use version 4.2; you cannot use later or
earlier versions. Note that there is also an XML
version of DocBook -- do not use that. ***

Regards,
Halley
 --- Peter Eisentraut <[email-masked]> escreveu: >

---

From: Joe Conway <[email-masked]>
Date: Fri, 28 Nov 2003 20:51:59 -0800

> several operating systems.  If you have trouble installing or using 4.2,

I found the HTML docs build fine for me on RH9 after doing:
export SGML_CATALOG_FILES==/etc/sgml/sgml-docbook.cat

But when trying to build PDF I get the following (actually I have not 
been able to build PDF since the "great docs consolidation" of the 7.4 
dev cycle):

[...lots of warnings similar to the next few lines...]
LaTeX Warning: Reference `XINDEX-RTREE-SUPPORT-TABLE' on page xxx 
undefined on
input line 37896.
LaTeX Warning: Reference `XINDEX-GIST-SUPPORT-TABLE' on page xxx 
undefined on i
nput line 37922.
! TeX capacity exceeded, sorry [save size=5000].
\SetupICs ...csname Posture@\fPosture \endcsname }
          \IfFileExists {t1\fFamName...
l.40734 {}
           \endSeq{}\endSeq{}\endSeq{}\endSeq{}\endSeq{}\Seq%
!  ==> Fatal error occurred, the output PDF file not finished!
Transcript written on postgres.log.
make: *** [postgres.pdf] Error 1
make: *** Deleting file `postgres.pdf'

Any ideas?

Thanks,

Joe