Subject: 8.2.0 pdf

From: Devrim GUNDUZ <[email-masked]>
Date: Mon, 04 Dec 2006 11:46:10 +0200

Hello,

I'm building 8.2.0 pdf now. It may take 3-4 days. I am writing this
e-mail to prevent duplicate work.

Regards,
-- 
The PostgreSQL Company - Command Prompt, Inc. 1.503.667.4564
PostgreSQL Replication, Consulting, Custom Development, 24x7 support
Managed Services, Shared and Dedicated Hosting
Co-Authors: plPHP, plPerlNG - http://www.commandprompt.com/

---

From: Oleg Bartunov <[email-masked]>
Date: Mon, 4 Dec 2006 16:21:08 +0300 (MSK)

> e-mail to prevent duplicate work.

Good luck ! My attempts failed after 2-4 days running. What's the mess !

> Regards,

 	Regards,
 		Oleg
_____________________________________________________________
Oleg Bartunov, Research Scientist, Head of AstroNet (www.astronet.ru),
Sternberg Astronomical Institute, Moscow University, Russia
Internet: [email-masked], http://www.sai.msu.su/~megera/
phone: +007(495)939-16-83, +007(495)939-23-83

---

From: Iannsp <[email-masked]>
Date: Tue, 05 Dec 2006 00:05:36 -0200

If you need some help like share te work...
I like to work with you on this.
ok.

Oleg Bartunov escreveu:
> ---------------------------(end of broadcast)---------------------------
> TIP 2: Don't 'kill -9' the postmaster
>

-- 
Ivo Nascimento
Iann tech - Desenvolvendo soluções com performance e segurança

---

From: Devrim GUNDUZ <[email-masked]>
Date: Thu, 07 Dec 2006 08:16:03 +0200

Hi,

On Mon, 2006-12-04 at 11:46 +0200, Devrim GUNDUZ wrote:
> I'm building 8.2.0 pdf now. It may take 3-4 days.

Ok, it is done. I'm now committing it to CVS. It will appear in web page
soon.

Regards,

---

From: Michael Glaesemann <[email-masked]>
Date: Thu, 7 Dec 2006 15:32:09 +0900

> Ok, it is done. I'm now committing it to CVS. It will appear in web  

Thanks, Devrim, for putting this together and your patience :). I'm  
sure people will find it useful.

Michael Glaesemann
grzm seespotcode net

---

From: Oleg Bartunov <[email-masked]>
Date: Thu, 7 Dec 2006 10:53:05 +0300 (MSK)

> Ok, it is done. I'm now committing it to CVS. It will appear in web page

Devrim, could you share your texmf.cnf ? My pdf creation failed even if
I increased memory setting as it's recommended in jadetex installation.

 	Regards,
 		Oleg

---

From: Devrim GUNDUZ <[email-masked]>
Date: Thu, 07 Dec 2006 10:03:51 +0200

Hi Oleg,

On Thu, 2006-12-07 at 10:53 +0300, Oleg Bartunov wrote:
> Devrim, could you share your texmf.cnf ? My pdf creation failed even
> if I increased memory setting as it's recommended in jadetex
> installation. 

I had to increase several settings in that file. 

http://www.gunduz.org/postgresql/texmf.cnf

Cheers,

---

From: Kris Jurka <[email-masked]>
Date: Thu, 07 Dec 2006 03:42:08 -0700

> Ok, it is done. I'm now committing it to CVS. It will appear in web page

The US version does not have bookmarks and doesn't seem to have any 
links internally.  Neither version has an index, you must build the HTML 
docs prior to the PDFs to get the indexes.

Kris Jurka

---

From: Devrim GUNDUZ <[email-masked]>
Date: Thu, 07 Dec 2006 13:18:45 +0200

Hi,

On Thu, 2006-12-07 at 03:42 -0700, Kris Jurka wrote:
> links internally.  Neither version has an index, you must build the
> HTML docs prior to the PDFs to get the indexes. 

Hmm. That makes sense. Per above, I now first ran "make html", and then
"make postgres.pdf". Here is the initial output:

------
LC_ALL=C "/usr/bin/perl" /usr/bin/collateindex.pl -f -g -i 'bookindex'
-o bookindex.sgml HTML.index
Processing HTML.index...
1555 entries loaded...
0 entries ignored...
...
-------

BTW, I first built A4 pdf by running "make postgres.pdf" . Then per a
suggestion at #postgresql, I converted it to ps by ps2pdf. Then, I ran:

ps2pdf -paper letter postgres.ps

to convert it to US format. Is it the right way to do that? 

Anyway, the process will again take 2-3 days.

Regards,

---

From: Kris Jurka <[email-masked]>
Date: Thu, 7 Dec 2006 06:29:05 -0500 (EST)

> to convert it to US format. Is it the right way to do that?

No, converting to postscript loses all the PDF formatting goodness that 
makes it readable instead of just printable.

I edited 
/usr/share/sgml/docbook/stylesheet/dsssl/modular/print/dbparam.dsl and 
changed

(define %paper-type% "A4")

to

(define %paper-type% "USletter")

and rerunning the entire multi-day generation.

Surely this isn't ideal and the correct way to do this is to set it in a 
stylesheet or pass it in some other way, but this worked for me.

Kris Jurka

---

From: Javier Molina <[email-masked]>
Date: Thu, 07 Dec 2006 14:39:39 +0100

Page numbers do not appear in the table of contents (they show as ??) 
starting from ALTER TABLESPACE (page xix), they were fine in 8.1.

Also, the last page of the document is titled "Index" but is otherwise 
empty (this was the case too in 8.1, is this expected?)

---

From: Devrim GUNDUZ <[email-masked]>
Date: Thu, 07 Dec 2006 18:32:46 +0200

Hi,

> starting from ALTER TABLESPACE (page xix), they were fine in 8.1. 

Yes, this was reported this morning -- I started to rebuild the pdf.

Regards,

---

From: Jim Nasby <[email-masked]>
Date: Fri, 8 Dec 2006 18:07:42 -0800

> http://www.gunduz.org/postgresql/texmf.cnf

ISTM that info should be in CVS, maybe in the README.

Also, if PDF indexes depend on HTML, perhaps HTML should be a  
dependency of PDF in the Makefile.
--
Jim Nasby                                            [email-masked]
EnterpriseDB      http://enterprisedb.com      512.569.9461 (cell)

---

From: Devrim GUNDUZ <[email-masked]>
Date: Sat, 09 Dec 2006 10:57:07 +0200

Hi Jim,

> ISTM that info should be in CVS, maybe in the README.

I was thinking something same. But I'd like to wait until I build a fine
PDF.

> dependency of PDF in the Makefile. 

Agreed...

Regards,

---

From: Peter Eisentraut <[email-masked]>
Date: Sat, 9 Dec 2006 12:01:01 +0100

> dependency of PDF in the Makefile.

By that logic, HTML should also depend on HTML.  I don't know how people 
would like that.

-- 
Peter Eisentraut
http://developer.postgresql.org/~petere/

---

From: Tom Lane <[email-masked]>
Date: Sat, 09 Dec 2006 12:57:40 -0500

> By that logic, HTML should also depend on HTML.  I don't know how people 

The real point is that the "jade" step needs to be done twice to have
up-to-date indexes.  It makes sense not to force that for html, because
we use html for proofing.  But perhaps we ought to run jade twice in the
Makefile rule for producing pdftex output?  I see that the Makefile
forces three runs of TeX for similar reasons (which is probably way more
time than the jade part anyway).

			regards, tom lane

---

From: Devrim GUNDUZ <[email-masked]>
Date: Sun, 10 Dec 2006 18:44:04 +0200

Hi,

> Yes, this was reported this morning -- I started to rebuild the pdf. 

I committed the new 8.2-A4 pdf to CVS -- it will hit the mirrors soon.  

Regards,

---

From: Peter Eisentraut <[email-masked]>
Date: Sun, 10 Dec 2006 21:47:22 +0100

Kris Jurka wrote:
> I edited
> /usr/share/sgml/docbook/stylesheet/dsssl/modular/print/dbparam.dsl
> and changed
>

I have changed this now so that there are separate targets 
postgres-A4.pdf and postgres-US.pdf, so there shouldn't be any 
confusion anymore in the future.

---

From: Tom Lane <[email-masked]>
Date: Sun, 10 Dec 2006 17:18:02 -0500

> confusion anymore in the future.

Could we get all these recent fixes back-ported into the 8.2 CVS branch?
Some of us still need to build .pdfs for 8.2 ...

			regards, tom lane

---

From: Devrim GUNDUZ <[email-masked]>
Date: Mon, 11 Dec 2006 00:27:31 +0200

Hi,

> Some of us still need to build .pdfs for 8.2 ... 

...and for 8.1, too? I would like to update 8.1 docs to 8.1.5.

Regards,

---

From: Javier Molina <[email-masked]>
Date: Mon, 11 Dec 2006 19:09:39 +0100

> I committed the new 8.2-A4 pdf to CVS -- it will hit the mirrors soon.  

Great, now I will be able to print it. Thanks!

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 14 Dec 2006 20:22:03 -0500 (EST)

> time than the jade part anyway).

I have modified the sgml Makefile to run jade twice for PDF and PS
output;  patch attached and applied to HEAD and 8.2.X.

-- 
  Bruce Momjian   [email-masked]
  EnterpriseDB    http://www.enterprisedb.com

  + If your life is a hard drive, Christ can be your backup. +
Index: doc/src/sgml/Makefile
===================================================================
RCS file: /cvsroot/pgsql/doc/src/sgml/Makefile,v
retrieving revision 1.84
diff -c -c -r1.84 Makefile
*** doc/src/sgml/Makefile	10 Dec 2006 20:46:03 -0000	1.84
--- doc/src/sgml/Makefile	15 Dec 2006 00:18:52 -0000
***************
*** 137,155 ****
--- 137,164 ----
  JADE.tex.call = $(JADE) $(JADEFLAGS) $(SGMLINCLUDE) $(CATALOG) -d $(srcdir)/stylesheet.dsl -t tex -V tex-backend -i output-print
  
  %-A4.tex-ps: %.sgml $(ALLSGML) stylesheet.dsl
+ 	# multiple runs are necessary to create proper index entries
+ 	$(JADE.tex.call) -V texdvi-output -V '%paper-type%'=A4 -o $@ $<
  	$(JADE.tex.call) -V texdvi-output -V '%paper-type%'=A4 -o $@ $<
  
  %-US.tex-ps: %.sgml $(ALLSGML) stylesheet.dsl
+ 	# multiple runs are necessary to create proper index entries
+ 	$(JADE.tex.call) -V texdvi-output -V '%paper-type%'=USletter -o $@ $<
  	$(JADE.tex.call) -V texdvi-output -V '%paper-type%'=USletter -o $@ $<
  
  %-A4.tex-pdf: %.sgml $(ALLSGML) stylesheet.dsl
+ 	# multiple runs are necessary to create proper index entries
+ 	$(JADE.tex.call) -V texpdf-output -V '%paper-type%'=A4 -o $@ $<
  	$(JADE.tex.call) -V texpdf-output -V '%paper-type%'=A4 -o $@ $<
  
  %-US.tex-pdf: %.sgml $(ALLSGML) stylesheet.dsl
+ 	# multiple runs are necessary to create proper index entries
+ 	$(JADE.tex.call) -V texpdf-output -V '%paper-type%'=USletter -o $@ $<
  	$(JADE.tex.call) -V texpdf-output -V '%paper-type%'=USletter -o $@ $<
  
  %.dvi: %.tex-ps
  	@rm -f $*.aux $*.log
+ 	# multiple runs are necessary to create proper index entries
  	jadetex $<
  	jadetex $<
  	jadetex $<
***************
*** 160,165 ****
--- 169,175 ----
  
  %.pdf: %.tex-pdf
  	@rm -f $*.aux $*.log $*.out
+ 	# multiple runs are necessary to create proper index entries
  	pdfjadetex $<
  	pdfjadetex $<
  	pdfjadetex $<