Subject: Conflict in documentation

From: PG Doc comments form <[email-masked]>
Date: Wed, 18 Mar 2026 11:17:10 +0000

The following documentation comment has been logged on the website:

Page: https://www.postgresql.org/docs/18/logical-replication-row-filter.html
Description:

On page
https://www.postgresql.org/docs/current/logical-replication-row-filter.html#LOGICAL-REPLICATION-ROW-FILTER-INITIAL-DATA-SYNC

If the subscription requires copying pre-existing table data and a
publication contains WHERE clauses, only data that satisfies the row filter
expressions is copied to the subscriber.

and

Warning
Because initial data synchronization does not take into account the publish
parameter when copying existing table data, some rows may be copied that
would not be replicated using DML. Refer to Section 29.9.1, and see Section
29.2.2 for examples.

conflict.

---

From: "David G. Johnston" <[email-masked]>
Date: Wed, 18 Mar 2026 07:14:49 -0700

On Wednesday, March 18, 2026, PG Doc comments form <[email-masked]>
wrote:

> https://www.postgresql.org/docs/current/logical-
> replication-row-filter.html#LOGICAL-REPLICATION-ROW-
> FILTER-INITIAL-DATA-SYNC
>
I don’t see a conflict.

But I also don’t really see the point of the warning - at least not with
its present wording.  There is the initial state and the change log (DML)
and comparing the two in this manner doesn’t make sense.

It’s seems a bit heavy to say: warning - publish does not apply to the
initial table sync.  It seems like it could easily just be a note; or
removed altogether as we try to avoid documenting what things don’t do.

That all said I’m not planning on trying to push for a change here.

David J.

---

From: "Blaziak, Sebastian" <[email-masked]>
Date: Wed, 18 Mar 2026 14:55:02 +0000

Hi David

The first line states that the initial data copy will _only_ copy filtered / relevant data.

While warning, but also elsewhere in the documentation it is stated that initial table _does not_ respect any publish limitations.

Hence the conflict.

Thx
Seb

From: David G. Johnston <[email-masked]>
Sent: Wednesday, 18 March 2026 15:15
To: Blaziak, Sebastian <[email-masked]>; [email-masked]
Subject: Re: Conflict in documentation

On Wednesday, March 18, 2026, PG Doc comments form <[email-masked]<mailto:[email-masked]>> wrote:
The following documentation comment has been logged on the website:

Page: https://www.postgresql.org/docs/18/logical-replication-row-filter.html<https://urldefense.com/v3/__https:/www.postgresql.org/docs/18/logical-replication-row-filter.html__;!!AI5hVGByxkJIiw!gGA2ppHJXssE1SEo1ijk9uf7nPnBuS2d5ZfjKS7l4zpkIV-Eskh3izNLfZtQ6T61OBUZ6UmEOg8iSmwHacnL0RrJhPFNtxNLYWHs$>
Description:

On page
https://www.postgresql.org/docs/current/logical-replication-row-filter.html#LOGICAL-REPLICATION-ROW-FILTER-INITIAL-DATA-SYNC<https://urldefense.com/v3/__https:/www.postgresql.org/docs/current/logical-replication-row-filter.html*LOGICAL-REPLICATION-ROW-FILTER-INITIAL-DATA-SYNC__;Iw!!AI5hVGByxkJIiw!gGA2ppHJXssE1SEo1ijk9uf7nPnBuS2d5ZfjKS7l4zpkIV-Eskh3izNLfZtQ6T61OBUZ6UmEOg8iSmwHacnL0RrJhPFNt8P9NTIY$>

and

Warning

conflict.

I don't see a conflict.

But I also don't really see the point of the warning - at least not with its present wording.  There is the initial state and the change log (DML) and comparing the two in this manner doesn't make sense.

It's seems a bit heavy to say: warning - publish does not apply to the initial table sync.  It seems like it could easily just be a note; or removed altogether as we try to avoid documenting what things don't do.

That all said I'm not planning on trying to push for a change here.

David J.

The information contained in this message is proprietary and/or confidential. If you are not the intended recipient, please: (i) delete the message and all copies; (ii) do not disclose, distribute or use the message in any manner; and (iii) notify the sender immediately. In addition, please be aware that any message addressed to our domain is subject to archiving and review by persons other than the intended recipient. Thank you.

---

From: "David G. Johnston" <[email-masked]>
Date: Wed, 18 Mar 2026 09:55:39 -0700

On Wed, Mar 18, 2026, 07:55 Blaziak, Sebastian <
[email-masked]> wrote:

> Hi David
>
>
>
> The first line states that the initial data copy will _*only*_ copy
> filtered / relevant data.
>
>
>
> While warning, but also elsewhere in the documentation it is stated that
> initial table _*does not*_ respect any publish limitations.
>
>
>
> Hence the conflict.
>
>
"publish" is a setting, it is completely orthogonal to the ability to
specify a "where" clause.

A where clause is always applied, both for the transfer of the ledger table
data and the transfer of journal event data.  The publish setting can only
ever apply to the transfer of journal event data by its very nature.

David J.