Subject: CREATE TABLE AS, section IF NOT EXISTS should clarify what happens to the data

From: PG Doc comments form <[email-masked]>
Date: Wed, 09 Feb 2022 13:02:51 +0000

The following documentation comment has been logged on the website:

Page: https://www.postgresql.org/docs/14/sql-createtableas.html
Description:

If I create a table with CREATE TABLE IF NOT EXISTS table_name AS, and the
table exists already, I get a NOTICE instead of an ERROR.

I wanted to have it clarified explicitly that the data from the SELECT
statement is ignored in this case.

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 14 Jul 2022 21:08:49 -0400

> statement is ignored in this case.

Good point.  Attached is a documentation patch to clarify this.

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  Indecision is a decision.  Inaction is an action.  Mark Batterson

diff --git a/doc/src/sgml/ref/create_table_as.sgml b/doc/src/sgml/ref/create_table_as.sgml
index 07558ab56c..4d6a1e72d5 100644
--- a/doc/src/sgml/ref/create_table_as.sgml
+++ b/doc/src/sgml/ref/create_table_as.sgml
@@ -100,9 +100,9 @@ CREATE [ [ GLOBAL | LOCAL ] { TEMPORARY | TEMP } | UNLOGGED ] TABLE [ IF NOT EXI
     <term><literal>IF NOT EXISTS</literal></term>
     <listitem>
      <para>
-      Do not throw an error if a relation with the same name already exists.
-      A notice is issued in this case. Refer to <xref linkend="sql-createtable"/>
-      for details.
+      Do not throw an error if a relation with the same name already
+      exists; simply issue a notice and leave the table unmodified. Refer
+      to <xref linkend="sql-createtable"/> for details.
      </para>
     </listitem>
    </varlistentry>

---

From: "David G. Johnston" <[email-masked]>
Date: Thu, 14 Jul 2022 18:47:19 -0700

> Good point.  Attached is a documentation patch to clarify this.
Not only is the existing table not modified, I think that the select query
portion of the command is never even executed.  That would seem to be
useful knowledge to have.

Maybe something like:

<para>
 Do not throw an error if a relation with the same name already exists.
 A notice is issued in this case.
 If <literal>WITH DATA</literal> is specified (the default) the execution
of the parsed query does not happen, leaving the existing table with its
existing contents.
</para>

I mention parsing since the command itself will fail if the query is
invalid even if a table already exists.  But any potential runtime errors
(or even side-effects) will not happen.

I've removed the xref to create table as there is nothing additional there
of material benefit - the sentence:

"Note that there is no guarantee that the existing relation is anything
like the one that would have been created."

is basically what we are adding here but this has more detail.

David J.

---

From: Bruce Momjian <[email-masked]>
Date: Mon, 18 Jul 2022 15:43:03 -0400

fOn Thu, Jul 14, 2022 at 06:47:19PM -0700, David G. Johnston wrote:
> portion of the command is never even executed.  That would seem to be useful
> knowledge to have.
> 
> Maybe something like:
> 
> <para>
>  If <literal>WITH DATA</literal> is specified (the default) the execution of
> the parsed query does not happen, leaving the existing table with its existing
> contents.
> </para>

I tried to go in that direction, but couldn't clearly name the
SELECT/VALUES part of the CREATE TABLE AS query because CREATE TABLE
AS is also a query.  I felt trying to say we ran the CREATE TABLE AS
query but not the SELECT/VALUES of the query was just too confusing.  I
used "simply issue a notice" as implying that nothing else happens,
which I considered sufficient.
> 
> I've removed the xref to create table as there is nothing additional there of
> material benefit - the sentence:

Okay, removed.  Updated patch attached.

diff --git a/doc/src/sgml/ref/create_table_as.sgml b/doc/src/sgml/ref/create_table_as.sgml
index 07558ab56c..8429333e3a 100644
--- a/doc/src/sgml/ref/create_table_as.sgml
+++ b/doc/src/sgml/ref/create_table_as.sgml
@@ -100,9 +100,8 @@ CREATE [ [ GLOBAL | LOCAL ] { TEMPORARY | TEMP } | UNLOGGED ] TABLE [ IF NOT EXI
     <term><literal>IF NOT EXISTS</literal></term>
     <listitem>
      <para>
-      Do not throw an error if a relation with the same name already exists.
-      A notice is issued in this case. Refer to <xref linkend="sql-createtable"/>
-      for details.
+      Do not throw an error if a relation with the same name already
+      exists; simply issue a notice and leave the table unmodified.
      </para>
     </listitem>
    </varlistentry>

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 12 Aug 2022 10:58:37 -0400

> Okay, removed.  Updated patch attached.

Patch applied back to PG 10.