Subject: Remove duplicate word in the ECPG documentation

From: Laurenz Albe <[email-masked]>
Date: Thu, 25 Dec 2025 21:17:14 +0100

The offending text in [1] is

  ..., which is defined in the functions complex_in() and complex_out() functions in Section 36.13.

One of the "functions" should go.  Patch attached.

Yours,
Laurenz Albe

 [1]: https://www.postgresql.org/docs/current/ecpg-variables.html#ECPG-VARIABLES-NONPRIMITIVE-SQL-USER-DEFINED-BASE-TYPES
From f21479d3640905c6a284aba449c03a9f460c510f Mon Sep 17 00:00:00 2001
From: Laurenz Albe <[email-masked]>
Date: Thu, 25 Dec 2025 21:13:20 +0100
Subject: [PATCH v1] Remove duplicate word in ECPG documentation

---
 doc/src/sgml/ecpg.sgml | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/doc/src/sgml/ecpg.sgml b/doc/src/sgml/ecpg.sgml
index 807dadcb4a3..cdd35d70837 100644
--- a/doc/src/sgml/ecpg.sgml
+++ b/doc/src/sgml/ecpg.sgml
@@ -1823,7 +1823,7 @@ while (1)
      representation of that type is <literal>(%f,%f)</literal>,
      which is defined in the
      functions <function>complex_in()</function>
-     and <function>complex_out()</function> functions
+     and <function>complex_out()</function>
      in <xref linkend="xtypes"/>.  The following example inserts the
      complex type values <literal>(1,1)</literal>
      and <literal>(3,3)</literal> into the
-- 
2.52.0

---

From: vignesh C <[email-masked]>
Date: Fri, 26 Dec 2025 11:27:40 +0530

> One of the "functions" should go.  Patch attached.

I agree, the changes look good.

Regards,
Vignesh

---

From: Michael Paquier <[email-masked]>
Date: Fri, 26 Dec 2025 15:26:45 +0900

> I agree, the changes look good.

Thanks, applied.
--
Michael