Subject: createfunction reference createprocedure

From: jian he <[email-masked]>
Date: Tue, 7 Jul 2026 16:48:36 +0800

Hi.

https://www.postgresql.org/docs/devel/sql-createprocedure.html
````
See Also
ALTER PROCEDURE, DROP PROCEDURE, CALL, CREATE FUNCTION
````

https://www.postgresql.org/docs/devel/sql-createfunction.html
```
See Also
ALTER FUNCTION, DROP FUNCTION, GRANT, LOAD, REVOKE
```

We can make sql-createfunction.html ``See Also`` section reference
CREATE PROCEDURE.
What do you think?

---

From: Laurenz Albe <[email-masked]>
Date: Tue, 07 Jul 2026 11:22:54 +0200

> We can make sql-createfunction.html ``See Also`` section reference

I think that is a good idea.

Yours,
Laurenz Albe

---

From: Daniel Gustafsson <[email-masked]>
Date: Tue, 7 Jul 2026 11:41:56 +0200

> On 7 Jul 2026, at 10:48, jian he <[email-masked]> wrote:

> CREATE PROCEDURE. What do you think?

Seems reasonable, would you like to send a patch?

--
Daniel Gustafsson

---

From: jian he <[email-masked]>
Date: Tue, 7 Jul 2026 19:47:08 +0800

> Seems reasonable, would you like to send a patch?

Please check the attached patch.
From b01af32437c63d9f4dfadb52ef7641cc1b520052 Mon Sep 17 00:00:00 2001
From: jian he <[email-masked]>
Date: Tue, 7 Jul 2026 19:45:30 +0800
Subject: [PATCH v1 1/1] Reference CREATE PROCEDURE in CREATE FUNCTION
 documentation

Update create_function.sgml to reference create_procedure.sgml.

Discussion: https://postgr.es/m/CACJufxFTi3ceVRJqWRr3L8GR5q%2BZhPCZw%3D1aDTaBGS1AugweFw%40mail.gmail.com
---
 doc/src/sgml/ref/create_function.sgml | 1 +
 1 file changed, 1 insertion(+)

diff --git a/doc/src/sgml/ref/create_function.sgml b/doc/src/sgml/ref/create_function.sgml
index 30bd4602f8d..5783d206f1e 100644
--- a/doc/src/sgml/ref/create_function.sgml
+++ b/doc/src/sgml/ref/create_function.sgml
@@ -937,6 +937,7 @@ COMMIT;
    <member><xref linkend="sql-grant"/></member>
    <member><xref linkend="sql-load"/></member>
    <member><xref linkend="sql-revoke"/></member>
+   <member><xref linkend="sql-createprocedure"/></member>
   </simplelist>
  </refsect1>
 
-- 
2.34.1

---

From: Daniel Gustafsson <[email-masked]>
Date: Tue, 7 Jul 2026 16:02:33 +0200

> On 7 Jul 2026, at 13:47, jian he <[email-masked]> wrote:
> 

Pushed with a small fix to maintain alphabetical order among the See Also
references.

--
Daniel Gustafsson