Subject: recovery configuration parameters

From: Fujii Masao <[email-masked]>
Date: Tue, 27 Apr 2010 21:03:15 +0900

Hi,

While the server configuration parameters are listed in
the index page, why not the recovery ones? It's very
inconvenient to be unable to reach the document of them
immediately when setting up the standby server.

How about listing the recovery configuration parameters
in the index page?

Regards,

-- 
Fujii Masao
NIPPON TELEGRAPH AND TELEPHONE CORPORATION
NTT Open Source Software Center

---

From: Heikki Linnakangas <[email-masked]>
Date: Tue, 27 Apr 2010 22:52:30 +0300

> How about listing the recovery configuration parameters

Agreed. This patch should do it. It lists them as "XXX recovery
parameter", e.g:

restore_command recovery parameter, Archive recovery settings

similar to the way GUCs are listed as "XXX configuration parameter".

PS. I just noticed that the links in the index for GUCs take you to the
section in the manual, not directly to the parameter. For example, when
you click on the index term for "max_connections", it takes you to
section "18.3.1 Connection Settings" (the link points to
http://developer.postgresql.org/pgdocs/postgres/runtime-config-connection.html#RUNTIME-CONFIG-CONNECTION-SETTINGS),
which begins with listen_addresses. max_connections is there a few
paragraphs down, but I would've expected the link to point directly to
description of the parameter.

-- 
  Heikki Linnakangas
  EnterpriseDB   http://www.enterprisedb.com

---

From: Fujii Masao <[email-masked]>
Date: Wed, 28 Apr 2010 11:16:43 +0900

On Wed, Apr 28, 2010 at 4:52 AM, Heikki Linnakangas
<[email-masked]> wrote:
> Agreed. This patch should do it.

Which patch?

> description of the parameter.

I think that such a direct link is useful, but I'm not sure how.
Though I added the "zone" attribute into the "indexterm" tag for
"max_connections" as a trial, I was not able to get the expected
result.

Regards,

---

From: Heikki Linnakangas <[email-masked]>
Date: Wed, 28 Apr 2010 09:19:06 +0300

>> Agreed. This patch should do it.

Ah, crap. This one.

-- 
  Heikki Linnakangas
  EnterpriseDB   http://www.enterprisedb.com
diff --git a/doc/src/sgml/recovery-config.sgml b/doc/src/sgml/recovery-config.sgml
index 3aff445..439db3f 100644
--- a/doc/src/sgml/recovery-config.sgml
+++ b/doc/src/sgml/recovery-config.sgml
@@ -36,6 +36,9 @@
 
      <varlistentry id="restore-command" xreflabel="restore_command">
       <term><varname>restore_command</varname> (<type>string</type>)</term>
+      <indexterm>
+        <primary><varname>restore_command</> recovery parameter</primary>
+      </indexterm>
       <listitem>
        <para>
         The shell command to execute to retrieve an archived segment of
@@ -72,6 +75,9 @@ restore_command = 'copy "C:\\server\\archivedir\\%f" "%p"'  # Windows
 
      <varlistentry id="restartpoint-command" xreflabel="restartpoint_command">
       <term><varname>restartpoint_command</varname> (<type>string</type>)</term>
+      <indexterm>
+        <primary><varname>restartpoint_command</> recovery parameter</primary>
+      </indexterm>
       <listitem>
        <para>
         This parameter specifies a shell command that will be executed at
@@ -98,6 +104,9 @@ restore_command = 'copy "C:\\server\\archivedir\\%f" "%p"'  # Windows
 
      <varlistentry id="recovery-end-command" xreflabel="recovery_end_command">
       <term><varname>recovery_end_command</varname> (<type>string</type>)</term>
+      <indexterm>
+        <primary><varname>recovery_end_command</> recovery parameter</primary>
+      </indexterm>
       <listitem>
        <para>
         This parameter specifies a shell command that will be executed once only
@@ -129,6 +138,9 @@ restore_command = 'copy "C:\\server\\archivedir\\%f" "%p"'  # Windows
       <term><varname>recovery_target_time</varname>
            (<type>timestamp</type>)
       </term>
+      <indexterm>
+        <primary><varname>recovery_target_time</> recovery parameter</primary>
+      </indexterm>
       <listitem>
        <para>
         This parameter specifies the time stamp up to which recovery
@@ -144,6 +156,9 @@ restore_command = 'copy "C:\\server\\archivedir\\%f" "%p"'  # Windows
 
      <varlistentry id="recovery-target-xid" xreflabel="recovery_target_xid">
       <term><varname>recovery_target_xid</varname> (<type>string</type>)</term>
+      <indexterm>
+        <primary><varname>recovery_target_xid</> recovery parameter</primary>
+      </indexterm>
       <listitem>
        <para>
         This parameter specifies the transaction ID up to which recovery
@@ -166,6 +181,9 @@ restore_command = 'copy "C:\\server\\archivedir\\%f" "%p"'  # Windows
       <term><varname>recovery_target_inclusive</varname>
         (<type>boolean</type>)
       </term>
+      <indexterm>
+        <primary><varname>recovery_target_inclusive</> recovery parameter</primary>
+      </indexterm>
       <listitem>
        <para>
         Specifies whether we stop just after the specified recovery target
@@ -185,6 +203,9 @@ restore_command = 'copy "C:\\server\\archivedir\\%f" "%p"'  # Windows
       <term><varname>recovery_target_timeline</varname>
         (<type>string</type>)
       </term>
+      <indexterm>
+        <primary><varname>recovery_target_timeline</> recovery parameter</primary>
+      </indexterm>
       <listitem>
        <para>
         Specifies recovering into a particular timeline.  The default is
@@ -207,6 +228,9 @@ restore_command = 'copy "C:\\server\\archivedir\\%f" "%p"'  # Windows
 
        <varlistentry id="standby-mode" xreflabel="standby_mode">
         <term><varname>standby_mode</varname> (<type>boolean</type>)</term>
+        <indexterm>
+          <primary><varname>standby_mode</> recovery parameter</primary>
+        </indexterm>
         <listitem>
          <para>
           Specifies whether to start the <productname>PostgreSQL</> server as
@@ -221,6 +245,9 @@ restore_command = 'copy "C:\\server\\archivedir\\%f" "%p"'  # Windows
        </varlistentry>
        <varlistentry id="primary-conninfo" xreflabel="primary_conninfo">
         <term><varname>primary_conninfo</varname> (<type>string</type>)</term>
+        <indexterm>
+          <primary><varname>primary_conninfo</> recovery parameter</primary>
+        </indexterm>
         <listitem>
          <para>
           Specifies a connection string to be used for the standby server
@@ -254,6 +281,9 @@ restore_command = 'copy "C:\\server\\archivedir\\%f" "%p"'  # Windows
        </varlistentry>
        <varlistentry id="trigger-file" xreflabel="trigger_file">
         <term><varname>trigger_file</varname> (<type>string</type>)</term>
+        <indexterm>
+          <primary><varname>trigger_file</> recovery parameter</primary>
+        </indexterm>
         <listitem>
          <para>
           Specifies a trigger file whose presence ends recovery in the

---

From: Fujii Masao <[email-masked]>
Date: Wed, 28 Apr 2010 16:06:56 +0900

>>> Agreed. This patch should do it.

Thanks! Seems good.

Regards,

---

From: Heikki Linnakangas <[email-masked]>
Date: Wed, 28 Apr 2010 10:34:33 +0300

>>>> Agreed. This patch should do it.

Ok, committed.