Subject: [PATCH] DOCS: Fix inconsistent text description punctuation in UPDATE FOR PORTION OF

From: "X-MAN" <[email-masked]>
Date: Mon, 25 May 2026 17:32:58 +0800

Hi,
I noticed an inconsistency in the documentation between UPDATE and DELETE&nbsp;
commands regarding the FOR PORTION OF clause description.&nbsp;

In doc/src/sgml/ref/update.sgml (line 169), the description reads:
&nbsp; "must be in the form ( portion ) where portion is an expression..."&nbsp;

In doc/src/sgml/ref/delete.sgml (line 166), it reads:
&nbsp;"must be&nbsp;in the form ( portion ), where portion is an expression..."&nbsp;

The UPDATE documentation misses a comma before "where" that DELETE has.
For consistency,&nbsp;add the comma to the UPDATE documentation to match DELETE.

I have recompiled the documentation and verified that
share/doc/postgresql/html/sql-update.html and
share/doc/postgresql/html/sql-delete.html are now consistent.

Best regards,
Zizhuan Liu

---

From: Paul A Jungwirth <[email-masked]>
Date: Mon, 25 May 2026 16:21:29 -0700

On Mon, May 25, 2026 at 2:33 AM X-MAN <[email-masked]> wrote:
>
> Hi,
> I noticed an inconsistency in the documentation between UPDATE and DELETE
> commands regarding the FOR PORTION OF clause description.
>
>   "must be in the form ( portion ) where portion is an expression..."
>
>  "must be in the form ( portion ), where portion is an expression..."

Thanks for the patch! This looks good to me.

Yours,

-- 
Paul              ~{:-)
[email-masked]

---

From: "X-MAN" <[email-masked]>
Date: Tue, 26 May 2026 09:59:13 +0800

&gt;On Mon, May 25, 2026 at 2:33 AM X-MAN <[email-masked]&gt; wrote:
&gt;&gt;
&gt;&gt; Hi,
&gt;&gt; I noticed an inconsistency in the documentation between UPDATE and DELETE
&gt;&gt; commands regarding the FOR PORTION OF clause description.
&gt;&gt;
&gt;&gt; In doc/src/sgml/ref/update.sgml (line 169), the description reads:
&gt;&gt; &nbsp; "must be in the form ( portion ) where portion is an expression..."
&gt;&gt;
&gt;&gt; In doc/src/sgml/ref/delete.sgml (line 166), it reads:
&gt;&gt; &nbsp;"must be in the form ( portion ), where portion is an expression..."
&gt;
&gt;Thanks for the patch! This looks good to me.
&gt;
&gt;Yours,
&gt;
&gt;--
&gt;Paul &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;~{:-)
&gt;[email-masked]

Thanks a lot for the review!

--
X-MAN (Zizhuan Liu)&nbsp;
[email-masked]