Subject: Re: COUNTs don't add up

From: "omid omoomi" <[email-masked]>
Date: Mon, 23 Jul 2001 20:34:13

hi ,
try this :
select species2, count(*) from homol_loclink group by species2;

it will show you.
Regards
Omid

>From: Alexander Turchin <[email-masked]>
>To: PostgreSQL Mailing List <[email-masked]>
>Subject: [GENERAL] COUNTs don't add up
>Date: Mon, 23 Jul 2001 15:32:04 -0400
>
>Hello all,
>
>I have a database where (I believe; the database was not made by me) one
>of the columns contains only two values: A or B. When I count all the
>rows in the database I get X; when I count the rows containing A or B in
>that column I get X-2; when I count the rows containing neither A nor B
>I get 0. Any explanation (hopefully, again, I am doing something wrong
>:)?
>
>The actual queries are found below.
>
>Thanks!
>
>Alex
>
>aturchin=# SELECT COUNT(*) FROM homol_loclink
>aturchin-# WHERE (species2 = 'Mus musculus') OR
>aturchin-# (species2 = 'Rattus norvegicus');
>  count
>-------
>   7110
>(1 row)
>
>aturchin=# SELECT COUNT(*) FROM homol_loclink;
>  count
>-------
>   7112
>(1 row)
>
>aturchin=# SELECT COUNT(*) FROM homol_loclink
>aturchin-# WHERE (species2 <> 'Mus musculus') AND
>aturchin-# (species2 <> 'Rattus norvegicus');
>  count
>-------
>      0
>(1 row)
>
>
>
>---------------------------(end of broadcast)---------------------------
>TIP 3: if posting/reading through Usenet, please send an appropriate
>subscribe-nomail command to [email-masked] so that your
>message can get through to the mailing list cleanly

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp

---

From: Alexander Turchin <[email-masked]>
Date: Mon, 23 Jul 2001 16:27:34 -0400

Yes, that turns out to be exactly the case - should have thought of it myself (of
course :).

Thanks!

Alex

[email-masked] wrote:

> Could species2 be null?  If so, I don't think those rows would appear when you
> test for <> 'somevalue'.
>
> Alexander Turchin <[email-masked]> on 07/23/2001
> 03:32:04 PM