Subject: Re: Intermittent errors when fetching cursor rows on PostgreSQL 16

From: Adrian Klaver <[email-masked]>
Date: Tue, 14 Jan 2025 09:56:33 -0800

On 1/13/25 11:56 PM, Enrico Schenone wrote:
> Il 13/01/25 18:26, Adrian Klaver ha scritto:

>> In your OP you stated:
>>
>> "Production environments can be:
>>
>>  * Distinct application server and DB server on distinct subnets (no
>>     dropped packet detected on firewall, no memory/disk/network failure
>>     detected by "nmon" tool)
>>   * Distinct application server and DB server on same subnet (no 
>> firewall)
>>   * Same server for PostgreSQL and applications
>> "
>>
>> In all those cases are the various servers all running completely 
>> within the providers infrastructure?
>>
> No, the second production environment is On Premises at the customer 
> Datacenter under the same vmware hypervisor.en

Which environment did you run the recent prolonged test against?

> I'll make more investigations on second and third environments by 
> increasing the verbosity of both DB and Application logs.
>
> *Enrico Schenone*
> Software Architect
> 

-- 
Adrian Klaver
[email-masked]

---

From: Enrico Schenone <[email-masked]>
Date: Wed, 15 Jan 2025 08:46:36 +0100

> Which environment did you run the recent prolonged test against?
The first one: Distinct application server and DB server on distinct 
subnets.
*Enrico Schenone*
Software Architect

---

From: Adrian Klaver <[email-masked]>
Date: Wed, 15 Jan 2025 08:03:33 -0800

> The first one: Distinct application server and DB server on distinct 

Is that the same as where you saw the errors?

---

From: Enrico Schenone <[email-masked]>
Date: Wed, 15 Jan 2025 18:10:41 +0100

> Is that the same as where you saw the errors?
Yes.