Subject: RE: Re: What's going on here?

From: "omid omoomi" <[email-masked]>
Date: Thu, 26 Jul 2001 20:35:18

any rule on this table?

>From: "Dave Cramer" <[email-masked]>
>Reply-To: <[email-masked]>
>To: <[email-masked]>
>Subject: RE: [GENERAL] Re: What's going on here?
>Date: Thu, 26 Jul 2001 15:46:23 -0400
>
>ebox=# select eitemcode,itemavail from inventory where
>eitemcode=6100122;
>  eitemcode | itemavail
>-----------+-----------
>    6100122 |         1
>(1 row)
>
>Dave
>
>-----Original Message-----
>From: [email-masked]
>[mailto:[email-masked]] On Behalf Of J.H.M. Dassen
>(Ray)
>Sent: July 26, 2001 3:24 PM
>To: [email-masked]
>Subject: [GENERAL] Re: What's going on here?
>
>
>Dave Cramer <[email-masked]> wrote:
> > ebox=# select version();
> >                            version
> > -------------------------------------------------------------
> >  PostgreSQL 7.0.3 on i686-pc-linux-gnu, compiled by gcc 2.96
>
>I wouldn't trust that build for production uses; see
>http://gcc.gnu.org/gcc-2.96.html .
>
> > ebox=# select eitemcode,itemavail from inventory where itemavail = 1
> > limit 1;  eitemcode | itemavail
> > -----------+-----------
> >    6100122 |         1
>
> > ebox=# update inventory set itemavail=0 where eitemcode=6100122;
> > UPDATE 0
>
>What do you get with "select eitemcode,itemavail from inventory where
>eitemcode=6100122"? "UPDATE 0" means no row matched the "where" clause.
>
>If this select does return rows, something truely weird is happening. If
>it does not return rows, there may be some kind of typing/casting issue
>at work.
>
>HTH,
>Ray
>--
>Javascript is EVIL!
>	keyweed
>
>
>---------------------------(end of broadcast)---------------------------
>TIP 4: Don't 'kill -9' the postmaster
>
>
>
>---------------------------(end of broadcast)---------------------------
>TIP 4: Don't 'kill -9' the postmaster

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp

---

From: "Dave Cramer" <[email-masked]>
Date: Thu, 26 Jul 2001 16:37:21 -0400

No, I don't think so

ebox=# select * from pg_rules 
ebox-# ;
 tablename | rulename | definition 
-----------+----------+------------
(0 rows)

-----Original Message-----
From: omid omoomi [mailto:[email-masked]] 
Sent: July 26, 2001 8:35 PM
To: [email-masked]; [email-masked]
Subject: RE: [GENERAL] Re: What's going on here?

any rule on this table?

>If this select does return rows, something truely weird is happening. 
>If it does not return rows, there may be some kind of typing/casting 
>issue at work.
>
>HTH,
>Ray
>--
>Javascript is EVIL!
>	keyweed
>
>

_________________________________________________________________
Get your FREE download of MSN Explorer at
http://explorer.msn.com/intl.asp