Subject: Re: UTC is not a time zone?

From: Adrian Klaver <[email-masked]>
Date: Mon, 13 May 2024 11:07:59 -0700

On 5/13/24 11:02 AM, Christophe Pettus wrote:
> 
> 
>> On May 13, 2024, at 10:58, Adrian Klaver <[email-masked]> wrote:
>>
>> You sure the timezone file did not get changed under the connection?
> 
> Yes (at least, nothing happened on the system that would indicate that).  The system wasn't touched during the execution (and, as noted, it worked after as well as before).

Hmm.

What does pg_config --configure show for '--with-system-tzdata' ?

> 
>> Why is SET TIMEZONE TO 'UTC being constantly called?
> 
> ORM noise.

-- 
Adrian Klaver
[email-masked]

---

From: Christophe Pettus <[email-masked]>
Date: Mon, 13 May 2024 11:09:24 -0700

> On May 13, 2024, at 11:07, Adrian Klaver <[email-masked]> wrote:
> 
> 

It's a local compile, and was built without that.

As an experiment, I'm just pounding the server with a single connection doing nothing but SET TIMEZONEs repeatedly.  So far, no break, but it is *very* intermittent.