Subject: Re: issue/bug management, project management, people management, product management all in one, preferably open source software ?

From: Albrecht Dreß <[email-masked]>
Date: Thu, 22 May 2025 19:33:30 +0000

Am 22.05.25 21:04 schrieb(en) Adrian Klaver:
> On 5/22/25 10:52, Achilleas Mantzios wrote:
> > Hi people
> > 
> > I'd like to know if people here know of or use any integrated solution 
> > for all or some of the above. It would be nice if it supported LDAP / 
> > OAuth 2.0 , integrate with plain vanilla git (not github / gitlab) and 
> > be open, and active as a project.
> 
> I use Redmine:
> 
> https://www.redmine.org/

+1 for Redmine!

Completely FOSS, written in Ruby.  I use it at work, with Postgres as backend, for hundreds of projects, and ~200 users and groups.  LDAP auth works ootb, for sync'ing LDAP users and groups a plugin is needed (search for “redmine ldap sync”, which is quite old and might need minor fixes or a forked version for the latest Redmine 6).  Never tried OAuth 2, but iirc a plugin is available.

You'll find a plethora of plugins (see <https://www.redmine.org/plugins>), both FOSS and closed-source, and it's pretty easy to write your own extensions (in Ruby, though, which is not my favourite language, but not too difficult).

Hth, Albrecht.

---

From: Achilleas Mantzios <[email-masked]>
Date: Wed, 28 May 2025 08:23:58 +0100

> You'll find a plethora of plugins (see <https://www.redmine.org/plugins>), both FOSS and closed-source, and it's pretty easy to write your own extensions (in Ruby, though, which is not my favourite…
Thank you, redmine is on the radar !