Subject: Re: PostgreSQL 15.9 Update: Partitioned tables with foreign key constraints

From: Adrian Klaver <[email-masked]>
Date: Tue, 19 Nov 2024 08:17:16 -0800

On 11/19/24 08:11, Paul Foerster wrote:
> Hi,
> 
> the PostgreSQL 15.9 release notes instruct to look out for especially detached partitions with foreign key constraints. I'm in the process of updating our databases from 15.8 to 15.9 now and found a case where the select statement returns a constraint.
> 
> The release notes say nothing about when to fix that using the generated add or drop statements.
> 
> Do I want/need to do that before or after I exchange the software? And if it is to be done on a particular of the two releases, why is that?
> 
> https://www.postgresql.org/docs/15/release-15-9.html
> Section E.1.2, changelog entry 5.
> 
> Any insight would be highly appreciated. Thanks in advance.

Read this:

https://www.postgresql.org/about/news/out-of-cycle-release-scheduled-for-november-21-2024-2958/

and hold off awhile.

> Cheers
> Paul

-- 
Adrian Klaver
[email-masked]

---

From: Paul Foerster <[email-masked]>
Date: Tue, 19 Nov 2024 20:08:20 +0100

Hi Adrian,

> On 19 Nov 2024, at 17:17, Adrian Klaver <[email-masked]> wrote:
> 
> Read this:
> 

Thanks very much. I will.

Cheers,
Paul