Subject: Re: create_immv issue on aws Ubuntu even after create extention

From: Adrian Klaver <[email-masked]>
Date: Sat, 1 Mar 2025 17:53:06 -0800

On 3/1/25 17:39, Krishnakant Mane wrote:

>>> But when I try creating the same immv on the server it says function 
>>> create_immv (unknown, unknown ) does not exist.
>>
>> Connect with psql then do:
>>
>> 1) \dx
>> This will show what extensions are installed and in what schema.
>>
>> 2) show search_path;
>>
>> 3) \df *.create_immv
>>
>> Provide the outputs from the above three commands in your response.

See above and provide answers.

-- 
Adrian Klaver
[email-masked]

---

From: Krishnakant Mane <[email-masked]>
Date: Sun, 2 Mar 2025 07:44:01 +0530

On 3/2/25 07:23, Adrian Klaver wrote:
>>>> But when I try creating the same immv on the server it says 
>>>> function create_immv (unknown, unknown ) does not exist.
>>>
pg_ivm | 1.10 | pg_catalog

plpgsql | 1.0 | pg_catalog.

>>> 2) show search_path;
>>> "$user" public.
>>> 3) \df *.create_immv
>>> pgivm | create_immv | bigint | text, text | func.
-- 
Email Signature
*Krishnakant Mane*
Software Architecture Design & Implementation Specialist 	

Mobile: 	
	+91 8424039903

https://www.linkedin.com/in/krishnakant-r-mane/

---

From: Adrian Klaver <[email-masked]>
Date: Sat, 1 Mar 2025 18:21:36 -0800

>> See above and provide answers.

So the extension functions are in the pgivm schema.

You will need to either always schema qualify the functions:

select pgivm.create_imv();

or  add the pgivm schema to the search_path.

For how to do that see the link I provided earlier in this thread:

https://www.postgresql.org/docs/current/ddl-schemas.html#DDL-SCHEMAS-PATH

Using the info from above you will probably want to persist the 
search_path setting in postgresql.conf as:

https://www.postgresql.org/docs/current/runtime-config-client.html

as

search_path

---

From: "David G. Johnston" <[email-masked]>
Date: Sat, 1 Mar 2025 19:24:54 -0700

On Saturday, March 1, 2025, Krishnakant Mane <[email-masked]> wrote:

> See this issue for why this is different now.

https://github.com/sraoss/pg_ivm/pull/116

Then deal with the fact it is no longer installed to pg_control but instead
pgivm. With usual schema qualifications or search_path techniques.

David J.

---

From: Krishnakant Mane <[email-masked]>
Date: Sun, 2 Mar 2025 08:06:27 +0530

On 3/2/25 07:54, David G. Johnston wrote:
> Then deal with the fact it is no longer installed to pg_control but 
> instead pgivm. With usual schema qualifications or search_path techniques.
> Thank you david.

Can you tell me how exactly should the syntax be?

Is my function definition wrong?

Mobile: 	
	+91 8424039903

---

From: Krishnakant Mane <[email-masked]>
Date: Sun, 2 Mar 2025 08:09:20 +0530

> instead pgivm. With usual schema qualifications or search_path techniques.
Thank you, it worked.  now pgivm.create_immv works.

I should have got it before.

Mobile: 	
	+91 8424039903

---

From: "David G. Johnston" <[email-masked]>
Date: Sat, 1 Mar 2025 19:40:36 -0700

> Can you tell me how exactly should the syntax be?

https://www.postgresql.org/docs/current/ddl-schemas.html

> Is my function definition wrong?

It isn’t a function definition, it is a function call.

David J.

---

From: Adrian Klaver <[email-masked]>
Date: Sat, 1 Mar 2025 19:14:25 -0800

> I should have got it before.

Did you not read my previous post?

---

From: Krishnakant Mane <[email-masked]>
Date: Sun, 2 Mar 2025 09:05:16 +0530

> Did you not read my previous post?
Actually I depend on a screen reader given my total blindness. Somehow 
it is playing some tricks with thunderbird these days.

Some times when there are multiple nested blocks, I may miss the text.

But any ways thank you very much.

I had doubted it on similar lines, but could not pinpoint the issue.

Regards.

Mobile: 	
	+91 8424039903

---

From: Adrian Klaver <[email-masked]>
Date: Sat, 1 Mar 2025 20:23:42 -0800

On 3/1/25 19:35, Krishnakant Mane wrote:

For my future reference does something like this response work better?

---

From: Krishnakant Mane <[email-masked]>
Date: Sun, 2 Mar 2025 12:05:21 +0530

Yes perfect thank you.

Besides, I will soon switch over to Mac air m3 and voice over does not 
have such problems.

This screen reader Orca is great as well and I am very sure, that it 
being open source, will have the issue fixed at the earliest.

Regards.

Mobile: 	
	+91 8424039903