Subject: Re: load fom csv

From: Andy Hartman <[email-masked]>
Date: Tue, 17 Sep 2024 11:35:31 -0400

I don't see anything in LOG

On Tue, Sep 17, 2024 at 11:23 AM Adrian Klaver <[email-masked]>
wrote:

> On 9/17/24 08:13, Andy Hartman wrote:
> > Still when I try to run from my powershell script it hangs...
> >
>
> And the Postgres log shows?
>
> --
> Adrian Klaver
> [email-masked]
>
>

---

From: Adrian Klaver <[email-masked]>
Date: Tue, 17 Sep 2024 08:39:03 -0700

> I don't see anything in LOG

1) Are you logging connections/disconnection per?:

https://www.postgresql.org/docs/current/runtime-config-logging.html#RUNTIME-CONFIG-LOGGING-WHAT

If not do so as it will show you if a connection is being attempted.

2) Do the commands work when run in psql or supplied directly to psql 
outside of PowerShell?

> 
> On Tue, Sep 17, 2024 at 11:23 AM Adrian Klaver 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     [email-masked] <mailto:[email-masked]>
>

---

From: Andy Hartman <[email-masked]>
Date: Tue, 17 Sep 2024 12:21:33 -0400

The command work outside of powershell  yes

---

From: Adrian Klaver <[email-masked]>
Date: Tue, 17 Sep 2024 09:25:32 -0700

> The command work outside of powershell  yes

Then you are going to need to use whatever debugging tools PowerShell 
has available to step through the script to figure out where the problem is.

---

From: Rob Sargent <[email-masked]>
Date: Tue, 17 Sep 2024 15:45:53 -0400

> On Sep 17, 2024, at 12:25 PM, Adrian Klaver <[email-masked]> wrote:
> 
> Then you are going to need to use whatever debugging tools PowerShell has available to step through the script to figure out where the problem is.
> 
> 

Visual Studio can run/debug PS 1 files. I am not at my desk but have done ps1 oneliner queries against mssql

Suggest echoing ALL vars used in psql command

---

From: Andy Hartman <[email-masked]>
Date: Tue, 17 Sep 2024 19:10:05 -0400

I'll echo vars and see if something looks strange.

THanks.