Subject: Re: Feature Request: Option for TLS no SSLRequest with psql

From: Joe Conway <[email-masked]>
Date: Sat, 11 May 2024 11:59:36 -0400

On 5/11/24 11:19, AJ ONeal wrote:
> Could we get a `postgrestls://` or `sslmode=tls` or --tls option that 
> instructs psql​ to sends straight TLS, skipping the 0000000804d2162f / 
> 0000000804d21630 + N / Y / S handshake?

You should probably be following the hackers mailing list. See:

https://www.postgresql.org/message-id/flat/CAM-w4HOEAzxyY01ZKOj-iq%3DM4-VDk%3DvzQgUsuqiTFjFDZaebdg%40mail.gmail.com

and commits:

https://git.postgresql.org/gitweb/?p=postgresql.git;a=commit;h=91044ae4baeac2e501e34164a69bd5d9c4976d21

https://git.postgresql.org/gitweb/?p=postgresql.git;a=commit;h=d39a49c1e459804831302807c724fa6512e90cf0

-- 
Joe Conway
PostgreSQL Contributors Team
RDS Open Source Databases
Amazon Web Services: https://aws.amazon.com

---

From: Joe Conway <[email-masked]>
Date: Sat, 11 May 2024 12:01:58 -0400

> https://git.postgresql.org/gitweb/?p=postgresql.git;a=commit;h=d39a49c1e459804831302807c724fa6512e90cf0

And as of a few moments ago:

https://git.postgresql.org/gitweb/?p=postgresql.git;a=commitdiff;h=407e0b023cdb449dde65fd370c6cc48f5b8a5579