Subject: Re: DISABLE TRIGGER doc wrong?

From: Ron Johnson <[email-masked]>
Date: Tue, 26 Aug 2025 09:08:35 -0400

On Tue, Aug 26, 2025 at 9:01 AM Dominique Devienne <[email-masked]>
wrote:

> On Tue, Aug 26, 2025 at 2:54 PM Ron Johnson <[email-masked]>
> wrote:
> > On Tue, Aug 26, 2025 at 3:01 AM Dominique Devienne <[email-masked]>
> wrote:
> >> ERROR:  permission denied: "RI_ConstraintTrigger_c_1226298044" is a
> >> (yes, that's a large OID... For a 1 year old DB)
> >
> > PG's OID allocation of "user-land" OIDs doesn't start at 16384 anymore.
>
> This is a 17 cluster. So not even 1 year old then.
> So getting to 1.2B OIDs in 10 months,
> doesn't bode well for the longevity of that cluster.
> But we're getting OT here.
> This is not a "production" server, lots of CIs and manual testing there.
>

Like I said, it's not completely linear.  The real question, though, is
whether PG looks for gaps in oid allocation once it wants to try and
allocate an oid of uint32 max.

I bet it does.  If it doesn't... pg_dump/pg_restore, baby!

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> lobster!

---

From: Tom Lane <[email-masked]>
Date: Tue, 26 Aug 2025 09:57:22 -0400

> allocate an oid of uint32 max.

OID counter wraparound is not particularly a problem.

			regards, tom lane