Subject: Re: pg_hint_tables

From: Adrian Klaver <[email-masked]>
Date: Tue, 30 Sep 2025 13:13:21 -0700

On 9/30/25 12:51, Wong, Kam Fook (TR Technology) wrote:
> I am trying to use pg_hint_tables in AWS Aurora Postgres.  I changed the Postgres parameter "pg_hint_plan.enable_hint_table = 1".  Then I logout but can't login anymore with the following error message.

To be clear it is pg_hint_plan not pg_hint_tables?

> 
> “postgres@postgres:[2719]:ERROR:  relation "hint_plan.hints" does not exist at character 21”.
> 
> I undo the changes, log back in.  Can't find a good resources that lead me to the root cause.  So I try a few other things, see below.  But no luck.  Any guidance or help is greatly appreciated.

 From here:

https://github.com/ossc-db/pg_hint_plan/blob/master/docs/installation.md

Did you do?:

"
Loading pg_hint_plan

pg_hint_plan does not require CREATE EXTENSION. Loading it with a LOAD 
command will activate it and of course you can load it globally by 
setting shared_preload_libraries in postgresql.conf. Or you might be 
interested in ALTER USER SET/ALTER DATABASE SET for automatic loading in 
specific sessions.

postgres=# LOAD 'pg_hint_plan';
LOAD
"
> 
> ALTER EXTENSION pg_hint_plan  UPDATE TO '1.4';
> GRANT SELECT, INSERT, UPDATE, DELETE ON hint_plan.hints TO PUBLIC;
> GRANT USAGE ON SCHEMA hint_plan TO PUBLIC;
> 
> Thank you
> Kam Fook Wong
-- 
Adrian Klaver
[email-masked]

---

From: Rob Sargent <[email-masked]>
Date: Tue, 30 Sep 2025 14:24:48 -0600

I am top posting because I believe you have “hikacked” a thread. 

Rather than replying to an existing thread unrelated to your topic you should start your own specific thread. 

> On Sep 30, 2025, at 2:13 PM, Adrian Klaver <[email-masked]> wrote:
> 
> pg_hint_plan does not require CREATE EXTENSION. Loading it with a LOAD command will activate it and of course you can load it globally by setting shared_preload_libraries in postgresql.conf. Or you might be interested in ALTER USER SET/ALTER DATABASE SET for automatic loading in specific sessions.
>