Subject: Re: Updating to PostgreSQL 17.5

From: Tom Lane <[email-masked]>
Date: Sun, 11 May 2025 15:36:09 -0400

Paul Foerster <[email-masked]> writes:
> the release notes for PostgreSQL 17.5 (https://www.postgresql.org/docs/17/release-17-5.html) state:
> "Also, if you have any BRIN bloom indexes, it may be advisable to reindex them after updating."

> I don't know what exactly that means.

Sorry --- it means BRIN indexes that use one of the "xxx_bloom_ops" opclasses.

https://www.postgresql.org/docs/current/brin.html#BRIN-BUILTIN-OPCLASSES

			regards, tom lane

---

From: Paul Foerster <[email-masked]>
Date: Sun, 11 May 2025 22:08:08 +0200

Hi Tom,

> On 11 May 2025, at 21:36, Tom Lane <[email-masked]> wrote:
> 

Ah, so that'd reduce my monster query to:

select
    concat ('reindex index "', schemaname, '"."', indexname, '";') as reindex_cmd
from
    pg_indexes
where
    indexdef ~ '_bloom_ops';

Thanks very much.

Paul