Subject: Re: CREATE DATABASE command concurrency

From: Christophe Pettus <[email-masked]>
Date: Wed, 18 Sep 2024 07:21:06 -0700

> On Sep 17, 2024, at 14:52, Wizard Brony <[email-masked]> wrote:
> 
> What are the concurrency guarantees of the CREATE DATABASE command? For example, is the CREATE DATABASE command safe to be called concurrently such that one command succeeds and the other reliably fails without corruption?

The concern is that two different sessions issue a CREATE DATABASE command using the same name?  In that case, it can be relied upon that one will succeed (unless it fails for some other reason, like lacking permissions), and the other will receive an error that the database already exists.

---

From: Tom Lane <[email-masked]>
Date: Wed, 18 Sep 2024 10:51:22 -0400

> The concern is that two different sessions issue a CREATE DATABASE command using the same name?  In that case, it can be relied upon that one will succeed (unless it fails for some other reason, li…

This is true, but it's possibly worth noting that the specific error
message you get could vary.  Normally it'd be something like

regression=# create database postgres;
ERROR:  database "postgres" already exists

but in a race condition it might look more like "duplicate key value
violates unique constraint".  In the end we rely on the system
catalogs' unique indexes to detect and prevent race conditions of
this sort.

			regards, tom lane