Subject: Libpq.dll

From: "[email-masked]" <[email-masked]>
Date: Wed, 6 Aug 2025 13:17:56 +0000 (GMT)

Hello, how are you? I'm asking for help. When I try to compile a 32-bit executable, in my 32-bit Delphi as well, in my 64-bit operating system, an error appears about libpq.dll, saying that it was found, but not loaded. Can you help me with this?

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 6 Aug 2025 18:24:06 +0000 (GMT)

2)

a) Windows 10 Home Single Language, Version 22H2

b) The settings and steps I followed were: first, I opened a project that already existed in my Delphi 10.2, then started editing it. I changed one of the project columns, and the message appeared:

"None of the dynamic libraries can be found or is not loadable: libpq.dll!

Use TZConnection.LibraryLocation if the location is invalid."

I then started working on the libpq.dll further, moving it to a few folders, and then the message changed to

"Error Message: Client-Library

libpq.dll found but could not be loaded. Check compile-target and library compatibility!" and then it remained with that message until now when I try to compile.

The executable's libpq is 32-bit, and its dependencies are correct and on the same architecture. In my Postgres, libpq was on a 64-bit architecture, so I downloaded the 32-bit libdll, and the error still persisted.

c)"Error Message: Client-Library

libpq.dll found but could not be loaded. Check compile-target and library compatibility!"

On ago 6 2025, at 2:46 pm, Adrian Klaver <[email-masked]> wrote:

On 8/6/25 06:17, [email-masked] wrote:
> Hello, how are you? I'm asking for help. When I try to compile a 32-bit
> executable, in my 32-bit Delphi as well, in my 64-bit operating system,
> an error appears about libpq.dll, saying that it was found, but not
> loaded. Can you help me with this?

1) Please do not use whatever HTML markup/image you wrote the previous
post in.

2) This needs more information:

a) OS and version of same.

b) The configuration and compilation steps you took.

c) The complete error message.

--
Adrian Klaver
[email-masked]