Subject: Re: phadmin4 app not starting after most recent upgrade

From: Richard Welty <[email-masked]>
Date: Mon, 27 Oct 2025 20:23:34 -0400

the package contains a web app and a desktop app. i have historically used

the desktop app.

richard

---- On Mon, 27 Oct 2025 17:35:43 -0400 Rob Sargent <[email-masked]> wrote ---

On Oct 27, 2025, at 10:20 AM, Richard Welty < mailto:[email-masked] > wrote:

i recently updated phadmin4 on my ubuntu 24.04 desktop from

the usual server. i just tried to launch the desktop app for the first

time since the update; it fails to launch with a warning about a failed

migration. i'm looking for suggestions of how to proceed.

thanks,

   richard

these are the package versions that are installed:

libpq-dev/pgadmin4 18.0-1.pgdg24.04+3 amd64

libpq5/pgadmin4,now 18.0-1.pgdg24.04+3 amd64 [installed,automatic]

pgadmin4-desktop/pgadmin4,now 9.9 amd64 [installed]

pgadmin4-server/pgadmin4,now 9.9 amd64 [installed,automatic]

pgadmin4-web/pgadmin4,now 9.9 all [installed,auto-removable]

pgadmin4/pgadmin4 9.9 all

phppgadmin/noble,noble 7.14.7+dfsg-1 all

this is the error that pops up.

The pgAdmin 4 server could not be contacted:

Is this by any chance a web app which needs to connect to a mothership?

---

From: Richard Welty <[email-masked]>
Date: Tue, 28 Oct 2025 12:26:01 -0400

so the problem was transient, pgadmin4 launged earlier.

on the other hand, my entire server configuraton has

vanished, which seems suboptimal.

richard

---- On Mon, 27 Oct 2025 20:23:34 -0400 Richard Welty <[email-masked]> wrote ---

the desktop app.

richard

---- On Mon, 27 Oct 2025 17:35:43 -0400 Rob Sargent < mailto:[email-masked] > wrote ---

thanks,

   richard